Les fonctions logiques : ET
Catégorie : EXCEL : Les fonctions utiles
Publié par Sebastien le 23-04-2006
Description : Renvoie VRAI si tous les arguments sont VRAI; renvoie FAUX si au moins l'un des arguments est FAUX.
Syntaxe : ET(valeur_logique1;valeur_logique2;...)

valeur_logique1,valeur_logique2, ... représentent les conditions à remplir. Il est possible de saisir jusqu'à 30 conditions.

Exemple :
Soit un tableau présentant les résultats de trois épreuves. Nous allons vérifier que la note de chaque épreuve est supérieure ou égale à 10.
La colonne état affichera VRAI si toutes les conditions sont remplies et FAUX si l'une des conditions n'est pas remplie.

Aperçu :
Exemple tableau fonction ET

Les critères seront (pour la ligne 3) :
valeur_logique1 : C3>=10
valeur_logique2 : D3>=10
valeur_logique3 : E3>=10

La formule sera :
=ET(C3>=10;D3>=10;E3>=10)


La fonction ET s'utilise généralement imbriquée dans une autre fonction logique. Nous allons donc refaire un exemple en utilisant la fonction ET imbriquée dans la fonction SI.

Exemple :
L'objectif est d'afficher OK si toutes les conditions sont remplies ou d'afficher ECHEC si l'une des conditions n'est pas remplie.

Aperçu :
Exemple fonction imbriquée SI ET

Les critères seront (pour la ligne 3) :
test_logique : ET(C3>=10;D3>=10;E3>=10) (cela signifie C3 supérieur ou égal à 10 ET D3 supérieur ou égal à 10 ET E3 supérieur ou égal à 10 )
valeur_si_vrai : OK
valeur_si_faux : ECHEC

La formule sera :
=SI(ET(C3>=10;D3>=10;E3>=10);"OK";"ECHEC")