Les fonctions Math et Trigo : SOMMEPROD
Catégorie : EXCEL : Les fonctions utiles
Publié par Sebastien le 27-08-2006
Description : Permet de calculer le produit des matrices spécifiées dans la formule puis de faire la somme de ces produits.
Syntaxe : SOMMEPROD(matrice1;matrice2;matrice3;...)

Note : Les matrices doivent avoir la même dimension. SOMMEPROD affecte la valeur 0 aux entrées de matrice non numériques.

Premier exemple :

Soit un tableau récapitulatif des ventes de hamburger et de salades de deux restaurants. Ce tableau propose les données suivantes : Année, Mois, emplacement du restaurant (Lille ou Paris), Type de produits (Hamburger ou Salade), nombre de produits vendus, prix de vente (en euros) et chiffre d'affaires (nombre de produits vendus * prix de vente).
Note : La colonne CA n'est présente que pour contrôler le résultat, le calcul étant effectué directement par la fonction SOMMEPROD.

Aperçu partiel du tableau :
Tableau récapitulatif des ventes



L'objectif est de calculer le chiffre d'affaire de Janvier 2005.

Les critères seront :
matrice1 : E7:E10
matrice2 : F7:F10

La formule sera :
=SOMMEPROD(E7:E10;F7:F10)

Aperçu :
SOMMEPROD : Premier exemple

Le résultat donne :
(2350*3)+(1550*4)+(2300*3)+(1500+4) = 26150
7050+6200+6900+6000 = 26150

Bien sûr, nous aurions pu faire le calcul avec une formule SOMME classique mais ce premier exemple avait pour but de calculer le CA sans utiliser la colonne CA (qui n'est là que pour contrôle). SOMMEPROD a donc calculé le chiffre d'affaires directement.

L'avantage de SOMMEPROD ne s'arrète pas là. En effet, il est possible d'ajouter des critères dans le calcul. C'est là que la fonction SOMMEPROD prend tout son intérêt. Nous allons pouvoir réaliser des calculs plus complèxes en ajoutant des conditions dans le calcul.



Deuxième exemple :

Dans le même tableau, nous allons effectuer les deux calculs suivants :


La fonction SOMMEPROD permet de rajouter des conditions dans le calcul. Ainsi, pour calculer la vente totale des hamburgers sur Lille en 2005, il faut utiliser la formule suivante :
=SOMMEPROD((A7:A102=2005)*(C7:C102="Lille")*(D7:D102="Hamburger")*(E7:E102))
Résultat : 40100

Aperçu :
SOMMEPROD : Deuxième exemple



Pour calculer le CA des ventes de salades sur Paris en 2006, la formule sera :
=SOMMEPROD((A7:A102=2006)*(C7:C102="Paris")*(D7:D102="Salade")*(E7:E102)*(F7:F102))
Résultat : 126800

Aperçu :
SOMMEPROD : Troisième exemple


On peut donc résumer :
La fonction SOMMEPROD peut s'utiliser de la façon suivante :
=SOMMEPROD((CONDITION_1)*(CONDITION_2")*(CONDITION_N)*(PLAGE_A_ADDITIONNER))