Les fonctions logiques : OU
Catégorie : EXCEL : Les fonctions utiles
Publié par Sebastien le 23-04-2006
Description : Renvoie la valeur VRAI si une des conditions est VRAI et la valeur FAUX si toutes les conditions sont fausses.
Syntaxe : OU(valeur_logique1;valeur_logique2,...)

valeur_logique1,valeur_logique2, ... représentent les conditions à remplir. Il est possible de saisir jusqu'à 30 conditions.

Exemple :
Soit un tableau présentant les résultats de trois épreuves. Nous allons vérifier que l'une des notes est supérieure ou égale à 16 ou que la moyenne soit supérieure ou égale à 14.
La colonne état affichera VRAI si l'une des conditions est remplie et FAUX si aucune des conditions n'est remplie.

Aperçu :
Exemple tableau fonction OU

Les critères seront (pour la ligne 3) :
valeur_logique1 : C3>=16
valeur_logique2 : D3>=16
valeur_logique3 : E3>=16
valeur_logique4 : F3>=14

La formule sera :
=OU(C3>=16;D3>=16;E3>=16;F3>=14)


La fonction OU s'utilise généralement imbriquée dans une autre fonction logique. Nous allons donc refaire un exemple en utilisant la fonction OU imbriquée dans la fonction SI.

Exemple :
L'objectif est d'afficher OK si l'une des conditions est remplie ou d'afficher ECHEC si aucune des conditions n'est remplie.

Aperçu :
Exemple tableau fonction imbriquée SI OU

Les critères seront (pour la ligne 3) :
test_logique : OU(C3>=16;D3>=16;E3>=16;F3>=14) (cela signifie C3 supérieur ou égal à 16 OU D3 supérieur ou égal à 16 OU E3 supérieur ou égal à 16 OU F3 supérieur ou égal à 14 )
valeur_si_vrai : OK
valeur_si_faux : ECHEC

=SI(OU(C3>=16;D3>=16;E3>=16;F3>=14);"OK";"ECHEC")


Exemple de formule avec trois fonctions logiques imbriquées :
Pour ce dernier exemple, nous allons créer une formule imbriquant la fonction SI, la fonction ET ainsi que la fonction OU.
L'objectif est d'afficher OK si la moyenne est supérieure ou égale à 10.
Si la moyenne est comprise entre 8 et 10 mais que l'une des notes est supérieure à 18, nous afficherons OK également.
Si aucune des conditions n'est remplie, nous afficherons ECHEC.

Aperçu du tableau :
Imbrication de fonctions SI, ET, OU

La formule sera :
=SI(F3>=10;"OK";SI(ET(OU(C3>=18;D3>=18;E3>=18);F3>8);"OK";"ECHEC"))

Test logique de la fonction SI : F3>=10
valeur_si_vrai : OK
valeur_si_faux : Seconde formule

Seconde formule : SI(ET(OU(C3>=18;D3>=18;E3>=18);F3>8);"OK";"ECHEC")
Test logique de la fonction SI : ET(OU(C3>=18;D3>=18;E3>=18);F3>8)
valeur_si_vrai : OK
valeur_si_faux : ECHEC