Les fonctions Informations : ESTERREUR
Catégorie : EXCEL : Les fonctions utiles
Publié par Sebastien le 10-03-2014
Descriptif : Permet de tester une valeur afin de vérifier si elle correspond à une erreur. La fonction renvoie VRAI si la valeur testée correspond à une erreur, et FAUX quand la valeur testée n'en contient pas.
Syntaxe : ESTERREUR(valeur)
Note : Les codes d'erreurs couverts par cette fonction sont : #N/A, #VALEUR!, #REF!, #DIV/0!, #NOMBRE!, #NOM? et #NUL!.

Remarque : L'intérêt de cette fonction et que l'on peut la combiner avec une fonction SI, afin de pouvoir modifier le résultat d'une cellule lorsqu'elle contient une erreur.

Exemple :
Soit un tableau listant les notes ainsi que la moyenne obtenues par des candidats. Tant que les cellules de notes ne contiennent pas de valeur, la formule retourne une erreur #DIV/0!.

Aperçu :
Excel : ESTERREUR

La fonction ESTERREUR, combinée à une fonction SI, va nous permettre d'afficher du vide à la place du code d'erreur.

Les critères seront (pour la ligne B8) :
test_logique : ESTERREUR(MOYENNE(B3:B7))
valeur_si_vrai : ""
valeur_si_faux : MOYENNE(B3:B7)

La formule sera (pour la cellule B8) :
=SI(ESTERREUR(MOYENNE(B3:B7));"";MOYENNE(B3:B7))

Aperçu du résultat :
Excel : ESTERREUR

La cellule affichera du vide lorsque la moyenne renverra une erreur, et le résultat correct si aucune erreur n'est détectée.


Autre exemple d'utilisation de cette fonction :
Lors de l'utilisation de la fonction RECHERCHEV, si une valeur n'est pas trouvée dans la table de référence, la fonction retourne une erreur #N/A. La fonction ESTERREUR, combinée à une fonction SI, permet d'éviter l'affichage de codes d'erreur.

Exemple :
Excel : ESTERREUR

Aperçu :
Excel : ESTERREUR

Les critères seront (pour la ligne B3) :
test_logique : ESTERREUR(RECHERCHEV(A3;$E$3:$F$7;2;0))
valeur_si_vrai : "Inconnu"
valeur_si_faux : RECHERCHEV(A3;$E$3:$F$7;2;0)

La formule sera (pour la cellule B3) :
=SI(ESTERREUR(RECHERCHEV(A3;$E$3:$F$7;2;0));"Inconnu";RECHERCHEV(A3;$E$3:$F$7;2;0))

Aperçu du résultat :
Excel : ESTERREUR

La cellule affichera "Inconnu" lorsque la valeur recherchée sera non trouvée par RECHERCHEV.