Recherche
Publicités
Question aléatoire
Pourquoi les onglets du gestionnaire des tâches ont-ils disparu ?

Publicités
Qui est en ligne
29 Personne(s) en ligne (9 Personne(s) connectée(s) sur Fiches Pratiques)

Utilisateurs: 0
Invités: 29

plus...
SmartSection is developed by The SmartFactory (http://www.smartfactory.ca), a division of INBOX Solutions (http://inboxinternational.com)
Fiches Pratiques > Bureautique > EXCEL : Les fonctions utiles > Les fonctions logiques : OU
Les fonctions logiques : OU
Publié par Sebastien le 23-04-2006 (177841 lus)
Description : Renvoie la valeur VRAI si une des conditions est VRAI et la valeur FAUX si toutes les conditions sont fausses.

Syntaxe : OU(valeur_logique1;valeur_logique2,...)

valeur_logique1,valeur_logique2, ... représentent les conditions à remplir. Il est possible de saisir jusqu'à 30 conditions.

Exemple :
Soit un tableau présentant les résultats de trois épreuves. Nous allons vérifier que l'une des notes est supérieure ou égale à 16 ou que la moyenne soit supérieure ou égale à 14.
La colonne état affichera VRAI si l'une des conditions est remplie et FAUX si aucune des conditions n'est remplie.

Aperçu :
Exemple tableau fonction OU

Les critères seront (pour la ligne 3) :
valeur_logique1 : C3>=16
valeur_logique2 : D3>=16
valeur_logique3 : E3>=16
valeur_logique4 : F3>=14

La formule sera :
=OU(C3>=16;D3>=16;E3>=16;F3>=14)


La fonction OU s'utilise généralement imbriquée dans une autre fonction logique. Nous allons donc refaire un exemple en utilisant la fonction OU imbriquée dans la fonction SI.

Exemple :
L'objectif est d'afficher OK si l'une des conditions est remplie ou d'afficher ECHEC si aucune des conditions n'est remplie.

Aperçu :
Exemple tableau fonction imbriquée SI OU

Les critères seront (pour la ligne 3) :
test_logique : OU(C3>=16;D3>=16;E3>=16;F3>=14) (cela signifie C3 supérieur ou égal à 16 OU D3 supérieur ou égal à 16 OU E3 supérieur ou égal à 16 OU F3 supérieur ou égal à 14 )
valeur_si_vrai : OK
valeur_si_faux : ECHEC

=SI(OU(C3>=16;D3>=16;E3>=16;F3>=14);"OK";"ECHEC")


Exemple de formule avec trois fonctions logiques imbriquées :
Pour ce dernier exemple, nous allons créer une formule imbriquant la fonction SI, la fonction ET ainsi que la fonction OU.
L'objectif est d'afficher OK si la moyenne est supérieure ou égale à 10.
Si la moyenne est comprise entre 8 et 10 mais que l'une des notes est supérieure à 18, nous afficherons OK également.
Si aucune des conditions n'est remplie, nous afficherons ECHEC.

Aperçu du tableau :
Imbrication de fonctions SI, ET, OU

La formule sera :
=SI(F3>=10;"OK";SI(ET(OU(C3>=18;D3>=18;E3>=18);F3>8);"OK";"ECHEC"))

Test logique de la fonction SI : F3>=10
valeur_si_vrai : OK
valeur_si_faux : Seconde formule

Seconde formule : SI(ET(OU(C3>=18;D3>=18;E3>=18);F3>8);"OK";"ECHEC")
Test logique de la fonction SI : ET(OU(C3>=18;D3>=18;E3>=18);F3>8)
valeur_si_vrai : OK
valeur_si_faux : ECHEC

Autres articles dans cette catégorie Date de publication clics
Les fonctions Informations : ESTERREUR
10-03-2014
10933
Les fonctions Informations : EST.PAIR
20-02-2014
4821
Les fonctions Informations : EST.IMPAIR
20-02-2014
3757
Les fonctions Math et Trigo : ARRONDI.AU.MULTIPLE
20-02-2014
5763
Les fonctions Math et Trigo : PLANCHER
10-10-2012
12669
Les fonctions Math et Trigo : PLAFOND
10-10-2012
7906
Les fonctions Date et Heure : DATE
06-09-2010
54010
Les fonctions Date et Heure : DATEVAL
06-09-2010
38562
Les fonctions Date et Heure : DATEDIF
14-09-2008
86651
Les fonctions Recherche et Matrices : DECALER
11-08-2007
72671
Les fonctions Math et Trigo : MOD
16-05-2007
29967
Les fonctions Math et Trigo : ENT
16-05-2007
24557
Les fonctions statistiques : PETITE.VALEUR
29-01-2007
47724
Les fonctions statistiques : GRANDE.VALEUR
29-01-2007
52099
Les fonctions Math et Trigo : TRONQUE
27-01-2007
25279
Les fonctions statistiques : FREQUENCE
23-01-2007
133902
Les fonctions statistiques : NB.SI
07-10-2006
132650
Les fonctions statistiques : NBVAL
07-10-2006
119666
Les fonctions statistiques : NB.VIDE
07-10-2006
35153
Les fonctions statistiques : NB
07-10-2006
49278
Les fonctions mathématiques : SOMME.SI
05-10-2006
97244
Les fonctions Date et Heure : ANNEE
04-10-2006
35024
Les fonctions recherche et matrices : LIGNE
27-09-2006
47322
Les fonctions Math et Trigo : ABS
11-09-2006
18109
Les fonctions date et heure : AUJOURDHUI
11-09-2006
69981
Les fonctions Math et Trigo : ARRONDI
04-09-2006
40989
Les fonctions Math et Trigo : SOMMEPROD
27-08-2006
62297
Les fonctions textes : TEXTE
03-08-2006
104488
Les fonctions textes : SUPPRESPACE
03-08-2006
33531
Les fonctions Math et Trigo : ROMAIN
23-07-2006
195105
Les fonctions textes : CNUM
01-07-2006
49405
Les fonctions textes : REMPLACER
01-07-2006
80931
Les fonctions textes : SUBSTITUE
27-06-2006
52730
Les fonctions Recherche et Matrices : RECHERCHEV
10-06-2006
178286
Les fonctions textes : CHERCHE
03-06-2006
153836
Les fonctions textes : NBCAR
29-05-2006
50279
Les fonctions statistiques : RANG
29-05-2006
69396
Les fonctions Recherche et Matrices : EQUIV
25-05-2006
91828
Les fonctions Recherche et Matrices : INDEX
25-05-2006
74849
Les fonctions statistiques : MAX
23-05-2006
20112
Les fonctions statistiques : MIN
23-05-2006
12144
Les fonctions textes : MINUSCULE
20-05-2006
18124
Les fonctions textes : MAJUSCULE
20-05-2006
19722
Les fonctions textes : NOMPROPRE
19-05-2006
23872
Les fonctions mathématiques : SOUS TOTAL
30-04-2006
89470
Les fonctions mathématiques : SOMME
26-04-2006
23650
Les fonctions statistiques : MOYENNE
26-04-2006
26849
Les fonctions statistiques : MOYENNE REDUITE
26-04-2006
30556
Les fonctions textes : CONCATENER
23-04-2006
125233
Les fonctions textes : DROITE
23-04-2006
40098
Les fonctions textes : STXT
23-04-2006
89567
Les fonctions textes : GAUCHE
23-04-2006
60801
Les fonctions logiques : OU
23-04-2006
177842
Les fonctions logiques : ET
23-04-2006
62619
Les fonctions logiques : SI
23-04-2006
79831
Les commentaires appartiennent à leurs auteurs. Nous ne sommes pas responsables de leur contenu.
Posté Commentaire en débat
Publicités