Recherche
Publicités
Question aléatoire
Comment ne plus basculer involontairement de AZERTY à QWERTY ?

Publicités
Qui est en ligne
31 Personne(s) en ligne (5 Personne(s) connectée(s) sur Fiches Pratiques)

Utilisateur(s): 0
Invité(s): 31

Plus ...
SmartSection is developed by The SmartFactory (http://www.smartfactory.ca), a division of INBOX Solutions (http://inboxinternational.com)
Fiches Pratiques > Bureautique > EXCEL : Les fonctions utiles > Les fonctions logiques : OU
Les fonctions logiques : OU
Publié par Sebastien le 23/04/2006 (160691 lus)
Description : Renvoie la valeur VRAI si une des conditions est VRAI et la valeur FAUX si toutes les conditions sont fausses.

Syntaxe : OU(valeur_logique1;valeur_logique2,...)

valeur_logique1,valeur_logique2, ... représentent les conditions à remplir. Il est possible de saisir jusqu'à 30 conditions.

Exemple :
Soit un tableau présentant les résultats de trois épreuves. Nous allons vérifier que l'une des notes est supérieure ou égale à 16 ou que la moyenne soit supérieure ou égale à 14.
La colonne état affichera VRAI si l'une des conditions est remplie et FAUX si aucune des conditions n'est remplie.

Aperçu :
Exemple tableau fonction OU

Les critères seront (pour la ligne 3) :
valeur_logique1 : C3>=16
valeur_logique2 : D3>=16
valeur_logique3 : E3>=16
valeur_logique4 : F3>=14

La formule sera :
=OU(C3>=16;D3>=16;E3>=16;F3>=14)


La fonction OU s'utilise généralement imbriquée dans une autre fonction logique. Nous allons donc refaire un exemple en utilisant la fonction OU imbriquée dans la fonction SI.

Exemple :
L'objectif est d'afficher OK si l'une des conditions est remplie ou d'afficher ECHEC si aucune des conditions n'est remplie.

Aperçu :
Exemple tableau fonction imbriquée SI OU

Les critères seront (pour la ligne 3) :
test_logique : OU(C3>=16;D3>=16;E3>=16;F3>=14) (cela signifie C3 supérieur ou égal à 16 OU D3 supérieur ou égal à 16 OU E3 supérieur ou égal à 16 OU F3 supérieur ou égal à 14 )
valeur_si_vrai : OK
valeur_si_faux : ECHEC

=SI(OU(C3>=16;D3>=16;E3>=16;F3>=14);"OK";"ECHEC")


Exemple de formule avec trois fonctions logiques imbriquées :
Pour ce dernier exemple, nous allons créer une formule imbriquant la fonction SI, la fonction ET ainsi que la fonction OU.
L'objectif est d'afficher OK si la moyenne est supérieure ou égale à 10.
Si la moyenne est comprise entre 8 et 10 mais que l'une des notes est supérieure à 18, nous afficherons OK également.
Si aucune des conditions n'est remplie, nous afficherons ECHEC.

Aperçu du tableau :
Imbrication de fonctions SI, ET, OU

La formule sera :
=SI(F3>=10;"OK";SI(ET(OU(C3>=18;D3>=18;E3>=18);F3>8);"OK";"ECHEC"))

Test logique de la fonction SI : F3>=10
valeur_si_vrai : OK
valeur_si_faux : Seconde formule

Seconde formule : SI(ET(OU(C3>=18;D3>=18;E3>=18);F3>8);"OK";"ECHEC")
Test logique de la fonction SI : ET(OU(C3>=18;D3>=18;E3>=18);F3>8)
valeur_si_vrai : OK
valeur_si_faux : ECHEC

Autres articles dans cette catégorie Date de publication clics
Les fonctions Informations : ESTERREUR
10/03/2014
3857
Les fonctions Informations : EST.PAIR
20/02/2014
2130
Les fonctions Informations : EST.IMPAIR
20/02/2014
1445
Les fonctions Math et Trigo : ARRONDI.AU.MULTIPLE
20/02/2014
2155
Les fonctions Math et Trigo : PLANCHER
10/10/2012
11441
Les fonctions Math et Trigo : PLAFOND
10/10/2012
7017
Les fonctions Date et Heure : DATE
06/09/2010
49452
Les fonctions Date et Heure : DATEVAL
06/09/2010
34694
Les fonctions Date et Heure : DATEDIF
14/09/2008
80008
Les fonctions Recherche et Matrices : DECALER
11/08/2007
68653
Les fonctions Math et Trigo : MOD
16/05/2007
28267
Les fonctions Math et Trigo : ENT
16/05/2007
22902
Les fonctions statistiques : PETITE.VALEUR
29/01/2007
43824
Les fonctions statistiques : GRANDE.VALEUR
29/01/2007
48347
Les fonctions Math et Trigo : TRONQUE
27/01/2007
23903
Les fonctions statistiques : FREQUENCE
23/01/2007
123417
Les fonctions statistiques : NB.SI
07/10/2006
124990
Les fonctions statistiques : NBVAL
07/10/2006
113962
Les fonctions statistiques : NB.VIDE
07/10/2006
33217
Les fonctions statistiques : NB
07/10/2006
46244
Les fonctions mathématiques : SOMME.SI
05/10/2006
90871
Les fonctions Date et Heure : ANNEE
04/10/2006
31831
Les fonctions recherche et matrices : LIGNE
27/09/2006
43593
Les fonctions Math et Trigo : ABS
11/09/2006
16961
Les fonctions date et heure : AUJOURDHUI
11/09/2006
65395
Les fonctions Math et Trigo : ARRONDI
04/09/2006
38619
Les fonctions Math et Trigo : SOMMEPROD
27/08/2006
59131
Les fonctions textes : TEXTE
03/08/2006
99670
Les fonctions textes : SUPPRESPACE
03/08/2006
31302
Les fonctions Math et Trigo : ROMAIN
23/07/2006
192428
Les fonctions textes : CNUM
01/07/2006
45301
Les fonctions textes : REMPLACER
01/07/2006
75635
Les fonctions textes : SUBSTITUE
27/06/2006
48397
Les fonctions Recherche et Matrices : RECHERCHEV
10/06/2006
160516
Les fonctions textes : CHERCHE
03/06/2006
142023
Les fonctions textes : NBCAR
29/05/2006
47218
Les fonctions statistiques : RANG
29/05/2006
63832
Les fonctions Recherche et Matrices : EQUIV
25/05/2006
86977
Les fonctions Recherche et Matrices : INDEX
25/05/2006
71112
Les fonctions statistiques : MAX
23/05/2006
19181
Les fonctions statistiques : MIN
23/05/2006
11451
Les fonctions textes : MINUSCULE
20/05/2006
17180
Les fonctions textes : MAJUSCULE
20/05/2006
18750
Les fonctions textes : NOMPROPRE
20/05/2006
22624
Les fonctions mathématiques : SOUS TOTAL
30/04/2006
81492
Les fonctions mathématiques : SOMME
26/04/2006
22404
Les fonctions statistiques : MOYENNE
26/04/2006
25248
Les fonctions statistiques : MOYENNE REDUITE
26/04/2006
27766
Les fonctions textes : CONCATENER
23/04/2006
118075
Les fonctions textes : DROITE
23/04/2006
37436
Les fonctions textes : STXT
23/04/2006
84206
Les fonctions textes : GAUCHE
23/04/2006
57078
Les fonctions logiques : OU
23/04/2006
160692
Les fonctions logiques : ET
23/04/2006
57103
Les fonctions logiques : SI
23/04/2006
74704
Les commentaires appartiennent à leurs auteurs. Nous ne sommes pas responsables de leur contenu.
Auteur Commentaire en débat
Publicités