Recherche
Publicités
Question aléatoire
Comment désactiver ClearType dans Internet Explorer 7 ?

Publicités
Qui est en ligne
34 Personne(s) en ligne (9 Personne(s) connectée(s) sur Fiches Pratiques)

Utilisateur(s): 0
Invité(s): 34

Plus ...
SmartSection is developed by The SmartFactory (http://www.smartfactory.ca), a division of INBOX Solutions (http://inboxinternational.com)
Fiches Pratiques > Bureautique > EXCEL : Les fonctions utiles > Les fonctions logiques : OU
Les fonctions logiques : OU
Publié par Sebastien le 23/04/2006 (165097 lus)
Description : Renvoie la valeur VRAI si une des conditions est VRAI et la valeur FAUX si toutes les conditions sont fausses.

Syntaxe : OU(valeur_logique1;valeur_logique2,...)

valeur_logique1,valeur_logique2, ... représentent les conditions à remplir. Il est possible de saisir jusqu'à 30 conditions.

Exemple :
Soit un tableau présentant les résultats de trois épreuves. Nous allons vérifier que l'une des notes est supérieure ou égale à 16 ou que la moyenne soit supérieure ou égale à 14.
La colonne état affichera VRAI si l'une des conditions est remplie et FAUX si aucune des conditions n'est remplie.

Aperçu :
Exemple tableau fonction OU

Les critères seront (pour la ligne 3) :
valeur_logique1 : C3>=16
valeur_logique2 : D3>=16
valeur_logique3 : E3>=16
valeur_logique4 : F3>=14

La formule sera :
=OU(C3>=16;D3>=16;E3>=16;F3>=14)


La fonction OU s'utilise généralement imbriquée dans une autre fonction logique. Nous allons donc refaire un exemple en utilisant la fonction OU imbriquée dans la fonction SI.

Exemple :
L'objectif est d'afficher OK si l'une des conditions est remplie ou d'afficher ECHEC si aucune des conditions n'est remplie.

Aperçu :
Exemple tableau fonction imbriquée SI OU

Les critères seront (pour la ligne 3) :
test_logique : OU(C3>=16;D3>=16;E3>=16;F3>=14) (cela signifie C3 supérieur ou égal à 16 OU D3 supérieur ou égal à 16 OU E3 supérieur ou égal à 16 OU F3 supérieur ou égal à 14 )
valeur_si_vrai : OK
valeur_si_faux : ECHEC

=SI(OU(C3>=16;D3>=16;E3>=16;F3>=14);"OK";"ECHEC")


Exemple de formule avec trois fonctions logiques imbriquées :
Pour ce dernier exemple, nous allons créer une formule imbriquant la fonction SI, la fonction ET ainsi que la fonction OU.
L'objectif est d'afficher OK si la moyenne est supérieure ou égale à 10.
Si la moyenne est comprise entre 8 et 10 mais que l'une des notes est supérieure à 18, nous afficherons OK également.
Si aucune des conditions n'est remplie, nous afficherons ECHEC.

Aperçu du tableau :
Imbrication de fonctions SI, ET, OU

La formule sera :
=SI(F3>=10;"OK";SI(ET(OU(C3>=18;D3>=18;E3>=18);F3>8);"OK";"ECHEC"))

Test logique de la fonction SI : F3>=10
valeur_si_vrai : OK
valeur_si_faux : Seconde formule

Seconde formule : SI(ET(OU(C3>=18;D3>=18;E3>=18);F3>8);"OK";"ECHEC")
Test logique de la fonction SI : ET(OU(C3>=18;D3>=18;E3>=18);F3>8)
valeur_si_vrai : OK
valeur_si_faux : ECHEC

Autres articles dans cette catégorie Date de publication clics
Les fonctions Informations : ESTERREUR
10/03/2014
6384
Les fonctions Informations : EST.PAIR
20/02/2014
3660
Les fonctions Informations : EST.IMPAIR
20/02/2014
2900
Les fonctions Math et Trigo : ARRONDI.AU.MULTIPLE
20/02/2014
3954
Les fonctions Math et Trigo : PLANCHER
10/10/2012
11771
Les fonctions Math et Trigo : PLAFOND
10/10/2012
7255
Les fonctions Date et Heure : DATE
06/09/2010
50839
Les fonctions Date et Heure : DATEVAL
06/09/2010
35754
Les fonctions Date et Heure : DATEDIF
14/09/2008
82004
Les fonctions Recherche et Matrices : DECALER
11/08/2007
69681
Les fonctions Math et Trigo : MOD
16/05/2007
28833
Les fonctions Math et Trigo : ENT
16/05/2007
23301
Les fonctions statistiques : PETITE.VALEUR
29/01/2007
44796
Les fonctions statistiques : GRANDE.VALEUR
29/01/2007
49239
Les fonctions Math et Trigo : TRONQUE
27/01/2007
24306
Les fonctions statistiques : FREQUENCE
23/01/2007
125909
Les fonctions statistiques : NB.SI
07/10/2006
126891
Les fonctions statistiques : NBVAL
07/10/2006
115469
Les fonctions statistiques : NB.VIDE
07/10/2006
33745
Les fonctions statistiques : NB
07/10/2006
46982
Les fonctions mathématiques : SOMME.SI
05/10/2006
92953
Les fonctions Date et Heure : ANNEE
04/10/2006
32704
Les fonctions recherche et matrices : LIGNE
27/09/2006
44471
Les fonctions Math et Trigo : ABS
11/09/2006
17276
Les fonctions date et heure : AUJOURDHUI
11/09/2006
66712
Les fonctions Math et Trigo : ARRONDI
04/09/2006
39316
Les fonctions Math et Trigo : SOMMEPROD
27/08/2006
60128
Les fonctions textes : TEXTE
03/08/2006
101184
Les fonctions textes : SUPPRESPACE
03/08/2006
31935
Les fonctions Math et Trigo : ROMAIN
23/07/2006
193368
Les fonctions textes : CNUM
01/07/2006
46391
Les fonctions textes : REMPLACER
01/07/2006
77065
Les fonctions textes : SUBSTITUE
27/06/2006
49597
Les fonctions Recherche et Matrices : RECHERCHEV
10/06/2006
165356
Les fonctions textes : CHERCHE
03/06/2006
145067
Les fonctions textes : NBCAR
29/05/2006
47990
Les fonctions statistiques : RANG
29/05/2006
65428
Les fonctions Recherche et Matrices : EQUIV
25/05/2006
88280
Les fonctions Recherche et Matrices : INDEX
25/05/2006
72133
Les fonctions statistiques : MAX
23/05/2006
19404
Les fonctions statistiques : MIN
23/05/2006
11648
Les fonctions textes : MINUSCULE
20/05/2006
17455
Les fonctions textes : MAJUSCULE
20/05/2006
19045
Les fonctions textes : NOMPROPRE
20/05/2006
22990
Les fonctions mathématiques : SOUS TOTAL
30/04/2006
83753
Les fonctions mathématiques : SOMME
26/04/2006
22728
Les fonctions statistiques : MOYENNE
26/04/2006
25707
Les fonctions statistiques : MOYENNE REDUITE
26/04/2006
28493
Les fonctions textes : CONCATENER
23/04/2006
120253
Les fonctions textes : DROITE
23/04/2006
38187
Les fonctions textes : STXT
23/04/2006
85554
Les fonctions textes : GAUCHE
23/04/2006
58121
Les fonctions logiques : OU
23/04/2006
165098
Les fonctions logiques : ET
23/04/2006
58581
Les fonctions logiques : SI
23/04/2006
75994
Les commentaires appartiennent à leurs auteurs. Nous ne sommes pas responsables de leur contenu.
Auteur Commentaire en débat
Publicités