• Publicité

Besoin d'aide pour une formule excel

Dans ce forum, vous pouvez poser toutes vos questions concernant l'utilisation de logiciels de bureautique (Microsoft Office, Open Office, etc.)

Modérateurs: Sebastien, Stéphane, Christophe

Besoin d'aide pour une formule excel

Messagepar LOrélye » 12 Déc 2008 16:04

bonjour,
voila je travaille sur excel 97 j'ai consulté votre site (vraiment bien d'ailleurs !) mais je n'ais pas trouvé réponse à mes problèmes : je cherche une formule pour des statistiques et qui me permette de calculer une tranche d'age
mon tableau est ainsi
C D E F G H I
sexe Age 1/25 26/35 36/45 45 et +
H F
3 1 25 [case F3]
4 1 30
5 1 26
6 1 38
7 1 59
...
la formule que j'utilise est actuellement celle-ci(ex pour la [case F3] =SI(E3>=1;E3<=25) )qui m'indique un résultat vrai / faux mais j'aimerais à la place du vrai un 1 et à la place du 0 rien mais j'ai beau essayé je ne trouve pas de formules autres qui fonctionnent.

Autre demande :) peut on différencier les hommes des femmes par tranche d'age ? y a t'il une formule ?

merci par avance de votre aide et bon courage
LOrélye
No0b
No0b
 
Messages: 3
Enregistré le: 12 Déc 2008 15:43

Re: Besoin d'aide pour une formule excel

Messagepar LOrélye » 12 Déc 2008 16:13

mince...
je viens de voir que mon petit tableau a perdu ses espaces
alors

colonne C D : sexe H et F (je remplie les cases par des 1)
colonne E : Age (je remplie par l'age de l'utilisateur)
colonne F : 1/25 ans
colonne G : 26/35
colonne H : 36/45
colonne I : 45 et +
ligne 3 : 1 (F) 25 (ans)
ligne 4 : 1 (h) 30 (ans)
ligne 5 : 1 (h) 26 (ans)
ligne 6 : 1 (f) 38 (ans)
7ligne : 1 (h) 59 (ans)
LOrélye
No0b
No0b
 
Messages: 3
Enregistré le: 12 Déc 2008 15:43

Re: Besoin d'aide pour une formule excel

Messagepar RTENLOIRE » 13 Déc 2008 22:04

Bonjour,

En F3 la formule à écrire est la suivante : = si(et(E3>=1 ;E3<=25) ;1 ; « »)
En clair
Si le contenu de E3 vérifie la condition >= 1 ET <=25 alors 1 sinon un blanc.
On emboîte 2 fonctions :
La condition à tester est une fonction : et(1ère condition ; 2ème condition)
La syntaxe est : si( condition logique testée ;réponse 1 si vrai ; sinon réponse 2)
La réponse 2 pourrait être de nouveau une fonction si … etc

Pour la programmation ,

1 il faut commencer par E3, puis la cellule E3 étant sélectionnée, la recopier en G3 H3 I3 à l’aide de la poignée de recopiage, en plaçant la flèche sur cette croix en bas à droite et en déplaçant la souris vers I 3.
Ainsi fait, il y aura un problème : la formule est recopiée mais E est transformé en F puis G puis H ; la recopie maintient le même intervalle dans la formule qu’entre E3 et F3 c’est à dire la cellule précédente.
Pour éviter cela il faut imposer la condition sur E3 en faisant précéder d’un $ on utilise des coordonnées absolues et non plus relatives à une autre cellule. On bloque la colonne.
La formule devient
= si(et($E3>=1 ;$E3<=25) ;1 ; « »)
Dans chaque formule on corrige les âges.

2 il faut recopier les cellules F3 à I3 vers le bas
on sélectionne les cellules avec la poignée de recopiage vers le bas
les indices des lignes sont modifiés E4 puis E5, mais cette fois ci pas de $ puisque cela nous arrange

Vous pouvez appliquer cela à H et F
Rq : je mettrais en C4 H plutôt que 1 c’est plus pratique.

Bon courage
René
RTENLOIRE
Carotteur
Carotteur
 
Messages: 39
Enregistré le: 13 Déc 2008 20:14

Re: Besoin d'aide pour une formule excel

Messagepar Sebastien » 13 Déc 2008 23:43

Bonsoir LOrélye et bienvenue sur le forum,

Pour illustrer les informations données par RTENLOIRE, je vous invite à consulter ces pages sur notre site internet. Vous pourrez y trouver des exemples d'utilisation des fonctions logiques Excel. Vous pourrez également trouver des exemples de formules imbriquées.


@+

PS : Merci à RTENLOIRE pour les explications précises et détaillées.
Image
Avatar de l’utilisateur
Sebastien
Administrateur
Administrateur
 
Messages: 5528
Enregistré le: 14 Fév 2005 19:17
Localisation: LILLE

Re: Besoin d'aide pour une formule excel

Messagepar RTENLOIRE » 15 Déc 2008 11:35

Bonjour,

Dénombrement en fonction de l’âge et du sexe (suite)

1- Créer les colonnes suivantes :
A
B
C : Sexe qui sera renseigné par H et F (casse à respecter)
D : Age
E : F 1/25 (ou autre libellé)
F : H 1/25
Idem pour G et H avec 26/35, pour I et J avec 36/45 et pour Ket L avec 46 et+
2- Formules de calcul
E3 : =SI(ET($D3>=1;$D3<=25;$C3="F");1;" ")
la fonction ET teste les 2 conditions d’âge et la condition de sexe ici F et vérifie si elles sont ou non valables simultanément (ET).

F3 : =SI(ET($D3>=1;$D3<=25;$C3="H");1;" ")
Il suffit de recopier E3 en F3 et de changer F en H

Par recopiages et modifications successives, on remplit :
G3 : =SI(ET($D3>=26;$D3<=35;$C3="F");1;" ")
H3 : =SI(ET($D3>=26;$D3<=35;$C3="H");1;" ")
I3 : =SI(ET($D3>=36;$D3<=45;$C3="F");1;" ")
J3 : =SI(ET($D3>=36;$D3<=45;$C3="H");1;" ")
K3 : =SI(ET($D3>=45;$D3<=125;$C3="F");1;" ")
L3 : =SI(ET($D3>=45;$D3<=125;$C3="H");1;" ")

Une recopie de E3 –L3 vers le bas finira le travail .

Bonne continuation
René
RTENLOIRE
Carotteur
Carotteur
 
Messages: 39
Enregistré le: 13 Déc 2008 20:14

Re: Besoin d'aide pour une formule excel

Messagepar LOrélye » 15 Déc 2008 12:31

Merci beaucoup pour vos réponses
je vais essayer ces formules dans la semaine et vous tiens informée
encore merci
bonne continuation à vous aussi
à bientot
aurélie
LOrélye
No0b
No0b
 
Messages: 3
Enregistré le: 12 Déc 2008 15:43


Retourner vers Forum d'entraide : Bureautique

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité

  • Publicité