• Publicité

Libeller une formule

Postez ici vos questions et(ou) vos solutions ayant pour thème les logiciels ou l'informatique en général. Vous pouvez également poser ici les questions informatiques qui n'auraient pas leur place dans les autres sections de notre forum d'entraide.

Modérateurs: Sebastien, Stéphane, Christophe

Libeller une formule

Messagepar declic » 14 Sep 2009 17:53

Dans cet exemple comment libeller une formule en sachant que minimun 5 résultats doit faire apparaître "C" dans la colonne "Class", par contre moins de cinq résultats doit faire apparaître "NC" dans la colonne"Class". Autrement dit, plus de 2 cellules vides seraient égales à "NC".

Nom Result1 Result2 Result3 Result4 Result5 Result6 Result7 Class
X 12 17 2 5 35 C
Y 2 23 5 NC
Z 1 6 8 24 6 8 24 C

Merci de m'aider!!!
declic
No0b
No0b
 
Messages: 20
Enregistré le: 12 Mai 2009 18:23

Re: Libeller une formule

Messagepar Sebastien » 14 Sep 2009 18:56

Bonjour,

Vous pouvez utiliser une formule SI combinée à une fonction NB.

Code: Tout sélectionner
=SI(NB(B2:H2)<5;"NC";"C")


Traduction :
Si le nombre de cellules (de la plage B2:H2) contenant une donnée numérique est inférieur à 5, alors afficher NC, sinon, afficher C.

Remarque : Cela fonctionne uniquement si les données saisies sont des chiffres. Sinon, il faut utiliser la fonction NBVAL.

Des informations sur les fonctions utilisées :

@+
Image
Avatar de l’utilisateur
Sebastien
Administrateur
Administrateur
 
Messages: 5561
Enregistré le: 14 Fév 2005 19:17
Localisation: LILLE

Re: Libeller une formule

Messagepar declic » 20 Sep 2009 10:06

Ok, merci cela fonctionne.
declic
No0b
No0b
 
Messages: 20
Enregistré le: 12 Mai 2009 18:23


Retourner vers Forum d'entraide informatique

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 3 invités

  • Publicité
cron