• Publicité

la fonction SI

Dans ce forum, vous pouvez poser toutes vos questions concernant l'utilisation de logiciels de bureautique (Microsoft Office, Open Office, etc.)

Modérateurs: Sebastien, Stéphane, Christophe

la fonction SI

Messagepar declic » 26 Nov 2009 18:05

Bonjour,

Je fais appel à vos connaissances pour résoudre mon problème que voici,

comme dans l'exemple ci-dessous, j'aimerais créer une formule en sachant que si B2=C et C2=C, C devrait s'inscrire en D2.
Par contre si B2=NC et C2=NC, NC devrait s'inscrire en D2. ou si B2=NC et C2=C, NC devrait s'inscrire en D2 ou alors si B2=C et C2=NC, NC devrait s'inscrire en D2.Schématiquement, la formule devrait ressembler à ceci, =si(B2="C";C2="C";"c";"nc"), mais cela ne fonctionne pas.

Image

Please, help me

Merci
declic
No0b
No0b
 
Messages: 20
Enregistré le: 12 Mai 2009 18:23

Re: la fonction SI

Messagepar Sebastien » 26 Nov 2009 23:30

Bonjour,

j'en déduis donc que C doit s'afficher uniquement s'il est indiqué C dans les deux cellules B2 et C2, sinon, c'est NC qui s'affiche.

On peut donc résumer tout ça en une imbrication de formule SI et ET.

Code: Tout sélectionner
=SI(ET(B2="C";C2="C");"C";"NC")


Voir les pages suivantes pour obtenir des explications sur les fonctions logiques SI et ET.
EXCEL : Les fonctions utiles > Les fonctions logiques : SI
EXCEL : Les fonctions utiles > Les fonctions logiques : ET

declic a écrit:=si(B2="C";C2="C";"c";"nc")

La fonction SI n'a que trois arguments : TEST LOGIQUE, VALEUR SI VRAI; VALEUR SI FAUX. Votre test logique doit remplir deux conditions (B2=C et C2=C), d'où l'utilisation de la fonction ET dans le test logique.
Après, il suffit d'imbriquer les fonctions.

@+
Image
Avatar de l’utilisateur
Sebastien
Administrateur
Administrateur
 
Messages: 5517
Enregistré le: 14 Fév 2005 19:17
Localisation: LILLE

Re: la fonction SI

Messagepar declic » 27 Nov 2009 19:10

Bonjour,

Un grand merci et mes félicitations pour le formidable travail fourni.

Le retraite
declic
No0b
No0b
 
Messages: 20
Enregistré le: 12 Mai 2009 18:23


Retourner vers Forum d'entraide : Bureautique

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 0 invités

  • Publicité
cron