• Publicité

extraction de valeurs numériques depuis excel 2010

Dans ce forum, vous pouvez poser toutes vos questions concernant l'utilisation de logiciels de bureautique (Microsoft Office, Open Office, etc.)

Modérateurs: Sebastien, Stéphane, Christophe

extraction de valeurs numériques depuis excel 2010

Messagepar eric_bsm » 06 Nov 2015 11:10

bonjour à tous,

je recherche comment extraire les valeurs depuis excel 2010
exemple:
cellule A1 = 179 Jour(s) 23 Heure(s) 20 Min(s)
je cherche à extraire 179 dans la cellule A2
puis 23 dans la cellule A3
et 20 dans la cellule A4

(A1 peut varier, cad que si il n'y a pas de jours seules les valeurs "heures" et "min" seront inscrites)

merci pour votre aide

eric
eric_bsm
No0b
No0b
 
Messages: 3
Enregistré le: 06 Nov 2015 11:05

Re: extraction de valeurs numériques depuis excel 2010

Messagepar Sebastien » 08 Nov 2015 17:41

Bonjour,

eric_bsm a écrit:je recherche comment extraire les valeurs depuis excel 2010
exemple:
cellule A1 = 179 Jour(s) 23 Heure(s) 20 Min(s)
je cherche à extraire 179 dans la cellule A2
puis 23 dans la cellule A3
et 20 dans la cellule A4

(A1 peut varier, cad que si il n'y a pas de jours seules les valeurs "heures" et "min" seront inscrites)


La formule est assez complexe parce qu'on va devoir gérer deux cas, celui où il y a des jours et celui où il n'y en a pas.

En A2 :
Code: Tout sélectionner
=SI(ESTERREUR(CHERCHE(" Jour(s)";A1));"";GAUCHE(A1;TROUVE(" Jour(s)";A1)-1))


En A3 :
Code: Tout sélectionner
=SI(ESTERREUR(CHERCHE(" Jour(s)";A1));GAUCHE(A1;TROUVE(" Heure(s)";A1)-1);STXT(A1;CHERCHE(" ";A1;TROUVE(" Jour(s)";A1)+1)+1;TROUVE(" Heure(s)";A1)-(CHERCHE(" ";A1;TROUVE(" Jour(s)";A1)+1)+1)))


En A4 :
Code: Tout sélectionner
=SI(ESTERREUR(CHERCHE(" Jour(s)";A1));STXT(A1;CHERCHE(" ";A1;TROUVE(" Heure(s)";A1)+1)+1;TROUVE(" Min(s)";A1)-(CHERCHE(" ";A1;TROUVE(" Heure(s)";A1)+1)+1));STXT(A1;CHERCHE(" ";A1;TROUVE(" Heure(s)";A1)+1)+1;TROUVE(" Min(s)";A1)-(CHERCHE(" ";A1;TROUVE(" Heure(s)";A1)+1)+1)))


A noter : La formule se base sur le format que vous avez décrit dans votre message (179 Jour(s) 23 Heure(s) 20 Min(s)). Si le format est modifié, la formule ne pourra plus fonctionner.

@+
Image
Avatar de l’utilisateur
Sebastien
Administrateur
Administrateur
 
Messages: 5506
Enregistré le: 14 Fév 2005 19:17
Localisation: LILLE

Re: extraction de valeurs numériques depuis excel 2010

Messagepar eric_bsm » 08 Nov 2015 18:11

bonsoir Sébastien,
Je viens de prendre connaissance de ta solution qui fonctionne à merveille.
Je te remercie vivement pour ton travail et te souhaite une bonne soirée.

cdlt

eric
eric_bsm
No0b
No0b
 
Messages: 3
Enregistré le: 06 Nov 2015 11:05


Retourner vers Forum d'entraide : Bureautique

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 3 invités

  • Publicité