• Publicité

Excel depuis colonnes transcrire les valeurs sur une ligne

Dans ce forum, vous pouvez poser toutes vos questions concernant l'utilisation de logiciels de bureautique (Microsoft Office, Open Office, etc.)

Modérateurs: Sebastien, Stéphane, Christophe

Excel depuis colonnes transcrire les valeurs sur une ligne

Messagepar bidani » 23 Juin 2017 13:10

Bonjour,

pouvez vous m'aider a résoudre le Probleme suivant (si possible sans macro)?

Explication: dans la colonne A se trouvent des chiffres qui ont des doublons. Dans la colonne B se trouvent une valeur différente.

Besoin: j'aurais besoin de transformer ce tableau de 2 colonnes en un tableau avec 1 seul ligne avec la valeur de la colonne A (sans doublons) et les valeurs de B en colonne B et C

par exemple:

a l'origine le tableau est
colonne A ... colonne B
abc ........... 10
abc ........... 12
acc ........... 11
acc ........... 15
cac ........... 13
cac ........... 14
etc...
Resultat souhaité:
colonne A ... colonne B ... colonne C
abc ........... 10 ........... 12
acc ........... 11 ........... 15
cac ........... 13 ........... 14
etc...

j'éspère avoir été assez clair dans l'exposé du Probleme.

Merci pour votre Aide :-D
bidani
No0b
No0b
 
Messages: 2
Enregistré le: 23 Juin 2017 11:51

Re: Excel depuis colonnes transcrire les valeurs sur une lig

Messagepar mdo100 » 24 Juin 2017 06:29

Bonjour bidani, toutes et tous,

Explication: dans la colonne A se trouvent des chiffres


Ce sont des nouveaux chiffres :lol: , car moi j'y vois des lettres et ça chance tout !

Voir dans le fichier joint:

Feuil1 "Données" en colonne "A" les lettres avec des doublons et en colonne "B" les valeurs numériques.

Feuil2 "Résultats" en colonne "A" les lettres sans doublons.

Code: Tout sélectionner
=SI(LIGNE(A1)>SOMME(1/NB.SI(Col_A;Col_A));"";INDEX(Col_A;EQUIV(MIN(SI(NB.SI(A$1:A1;Col_A)=0;NB.SI(Col_A;"<"&Col_A)));NB.SI(Col_A;"<"&Col_A);0)))


Feuil2 "Résultats" en colonnes "B & C" les valeurs numériques transposées.

Code: Tout sélectionner
=SI($A2<>"";SI(ESTERREUR(INDEX(Données!$B$2:$B$12;PETITE.VALEUR(SI(Données!$A$2:$A$12=$A2;LIGNE(Données!$A$2:$A$12)-1;"");COLONNE()-1)));"";INDEX(Données!$B$2:$B$12;PETITE.VALEUR(SI(Données!$A$2:$A$12=$A2;LIGNE(Données!$A$2:$A$12)-1;"");COLONNE()-1)));"")

Ce sont des formules matricielles, ce qui veut dire qu'il faut les valider avec les touches ctrl + maj + entrée

Voir aussi dans le "Gestionnaire de noms" ou j'ai nommé "Col_A" pour la première formule avec cette formule:

Code: Tout sélectionner
=DECALER(Données!$A$2;;;NBVAL(Données!$A:$A)-1)


Enfin je te joins un fichier exemple ICI==> http://www.cjoint.com/c/GFyfbM5w5Hu

Cordialement.
mdo100
Trolleur
Trolleur
 
Messages: 57
Enregistré le: 02 Juil 2016 20:24

Re: Excel depuis colonnes transcrire les valeurs sur une lig

Messagepar bidani » 26 Juin 2017 07:01

Bonjour mdo100

un grand merci pour ton aide, je vais essayer tes formules düs que possible (et essayer de les comprendre).
Je te tiens au courant.

Merci :-D
bidani
No0b
No0b
 
Messages: 2
Enregistré le: 23 Juin 2017 11:51


Retourner vers Forum d'entraide : Bureautique

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 9 invités

  • Publicité