• Publicité

Excel : Décodage chiffre "01" en texte "JANVIER"

Postez ici vos questions et(ou) vos solutions ayant pour thème les logiciels ou l'informatique en général. Vous pouvez également poser ici les questions informatiques qui n'auraient pas leur place dans les autres sections de notre forum d'entraide.

Modérateurs: Sebastien, Stéphane, Christophe

Excel : Décodage chiffre "01" en texte "JANVIER"

Messagepar Kdraguet » 10 Nov 2017 12:33

Bonjour,

Un tout grand merci de votre aide. Elle m'a été précieuse.

J'aurais une autre question pour pouvoir créer une formule particulière:
J'ai une colonne A, et une colonne B contenant une date.
Je voudrais:
Si la colonne B contient 01, alors la colonne A = Janvier
Si la colonne B contient 02, alors la colonne A = Février
Si la colonne B contient 03, alors la colonne A = Mars
Si la colonne B contient 04, alors la colonne A = Avril
Et ainsi de suite jusque décembre.

Est-il possible de créer une formule automatique entre ces deux cellules?

Merci d'avance,
Bonne fin de semaine à vous

Karen
Modifié en dernier par Sebastien le 10 Nov 2017 19:50, modifié 1 fois.
Raison: Division de sujet et modification du titre
Kdraguet
No0b
No0b
 
Messages: 9
Enregistré le: 03 Nov 2017 10:24

Re: Excel : Décodage chiffre "01" en texte "JANVIER"

Messagepar Sebastien » 10 Nov 2017 20:08

Bonjour,

Kdraguet a écrit:J'ai une colonne A, et une colonne B contenant une date.
Je voudrais:
Si la colonne B contient 01, alors la colonne A = Janvier
Si la colonne B contient 02, alors la colonne A = Février
Si la colonne B contient 03, alors la colonne A = Mars
Si la colonne B contient 04, alors la colonne A = Avril
Et ainsi de suite jusque décembre.


Vous pouvez utiliser la fonction SI.MULTIPLE()

SI le chiffre "01" est dans la cellule B1, dans la cellule A1, tapez la formule suivante :
Code: Tout sélectionner
=SI.MULTIPLE(B1;"01";"JANVIER";"02";"FEVRIER";"03";"MARS";"04";"AVRIL";"05";"MAI";"06";"JUIN";"07";"JUILLET";"08";"AOUT";"09";"SEPTEMBRE";"10";"OCTOBRE";"11";"NOVEMBRE";"12";"DECEMBRE")


La syntaxe :
SI.MULTIPLE(expression; valeur1; résultat1; [valeur par défaut ou valeur2; résultat2];…[valeur par défaut ou valeur3; résultat3])
  • expression = la cellule qui contient le texte à décoder
  • valeur1 = la première valeur cherchée (01 dans votre cas)
  • résultat1 = le texte à afficher quand on trouve la valeur1 (JANVIER dans votre cas).

On peut aller jusqu'à 126 paires à transcoder avec cette formule.

@+
Image
Avatar de l’utilisateur
Sebastien
Administrateur
Administrateur
 
Messages: 5414
Enregistré le: 14 Fév 2005 19:17
Localisation: LILLE

Re: Excel : Décodage chiffre "01" en texte "JANVIER"

Messagepar Kdraguet » 15 Nov 2017 08:26

Bonjour,

Merci de votre retour. La formule ne fonctionne pas dans mon fichier :-(

--> #NOM? ("Erreur due à un nombre non valide")

Je travaille sur Excel 2007... Je ne sais pas si ça peut être lié...

Merci d'avance,

Bien à vous

karen
Kdraguet
No0b
No0b
 
Messages: 9
Enregistré le: 03 Nov 2017 10:24

Re: Excel : Décodage chiffre "01" en texte "JANVIER"

Messagepar Sebastien » 15 Nov 2017 22:34

Bonjour,

Apparemment, cette formule semble disponible sur Office 365 (donc Excel 2016). Vu que vous avez Excel 2007, il va falloir passer par une fonction RECHERCHEV.
Sur la page suivante, vous trouverez des explications sur la fonction : http://www.astucesinternet.com/modules/smartsection/item.php?itemid=22

Dans votre cas, il faudra créer un tableau (soit dans votre feuille en cours, soit dans une autre feuille de votre classeur) qui contiendra dans la première colonne le texte à transcoder (01, 02, etc.) et dans la deuxième colonne le texte à afficher (JANVIER, FÉVRIER, etc.)

La formule RECHERCHEV ira chercher dans ce tableau la valeur de la colonne 1 pour afficher la donnée contenue dans la colonne 2.

J'ai fait un fichier pour exemple : https://www.astucesinternet.com/data/images_forum/2017-11-15-recherchev.zip

Dans le cellule A1 : =RECHERCHEV(B1;$D$1:$E$12;2;0)
Dans la cellule B1, le texte qu'on veut transcoder (01 par exemple)

La formule en A1 va chercher la valeur contenu dans B1 (01) dans la table matrice allant de D1 à E12 et l'afficher en A1. Dans notre cas, elle va afficher JANVIER.

@+
Image
Avatar de l’utilisateur
Sebastien
Administrateur
Administrateur
 
Messages: 5414
Enregistré le: 14 Fév 2005 19:17
Localisation: LILLE

Re: Excel : Décodage chiffre "01" en texte "JANVIER"

Messagepar Kdraguet » 05 Déc 2017 12:25

Un super grand merci pour votre aide précieuse :-)
Kdraguet
No0b
No0b
 
Messages: 9
Enregistré le: 03 Nov 2017 10:24

Re: Excel : Décodage chiffre "01" en texte "JANVIER"

Messagepar Kdraguet » 29 Jan 2018 11:04

Bonjour,

Je reviens à nouveau vers vous à ce sujet.
J'ai appliqué vos conseils et, jusqu'ici, cela semble fonctionner.
Toutefois, il y a une nouvelle donnée à intégrer.

En gardant toujours la même structure que précédemment:
---------------------------
"J'ai une colonne A, et une colonne B contenant une date.
Je voudrais:
Si la colonne B contient 01, alors la colonne A = Janvier
Si la colonne B contient 02, alors la colonne A = Février
Si la colonne B contient 03, alors la colonne A = Mars
Si la colonne B contient 04, alors la colonne A = Avril
Et ainsi de suite jusque décembre"
--------------------------
Je voudrais ajouter que : Si la colonne B est vide, alors A = Vide lui aussi.

Est-ce que c'est possible?

Merci d'avance :-)

Bonne journée à vous

Karen
Kdraguet
No0b
No0b
 
Messages: 9
Enregistré le: 03 Nov 2017 10:24

Re: Excel : Décodage chiffre "01" en texte "JANVIER"

Messagepar Sebastien » 30 Jan 2018 20:58

Bonjour,

Oui c'est possible, il suffit d'ajouter une condition dans la formule.
Dans l'ancienne formule, si on laissait la cellule B vide, ou si on indiquait une donnée qui n'est pas dans la matrice (13 par exemple), on avait une erreur de type #N/A.

En ajoutant une condition sur la présence d'une erreur, on peut modifier la formule.

Code: Tout sélectionner
=SI(ESTERREUR(RECHERCHEV(B1;$D$1:$E$12;2;0));"";RECHERCHEV(B1;$D$1:$E$12;2;0))


On ajoute la condition suivante : SI la formule renvoie une erreur, on affiche du vide. Ça devrait résoudre votre problème.

@+
Image
Avatar de l’utilisateur
Sebastien
Administrateur
Administrateur
 
Messages: 5414
Enregistré le: 14 Fév 2005 19:17
Localisation: LILLE


Retourner vers Forum d'entraide informatique

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 6 invités

  • Publicité