• Publicité

Formule excel 2016

Dans ce forum, vous pouvez poser toutes vos questions concernant l'utilisation de logiciels de bureautique (Microsoft Office, Open Office, etc.)

Modérateurs: Sebastien, Stéphane, Christophe

Formule excel 2016

Messagepar ANTOINE64 » 19 Mar 2018 11:39

Bonjour,
Explication: Je souhaiterais en H14 une date a + 3 jours de celle indiquée en C6 ou D8. Soit:
- La date en C6 à condition que( D7+F7+H7)=F6 et différent de 0.
- La date en D8 à condition que G8 soit remplie.
dans l'attente de vous lire
Cordialement
ANTOINE64
No0b
No0b
 
Messages: 5
Enregistré le: 19 Mar 2018 11:35

Re: Formule excel 2016

Messagepar Sebastien » 19 Mar 2018 22:37

Bonjour,

Que fait on lorsque ces deux conditions sont remplies ?
- La date en C6 à condition que( D7+F7+H7)=F6 et différent de 0.
et
- La date en D8 à condition que G8 soit remplie.

On prends C6 ou D8 ?

@+
Image
Avatar de l’utilisateur
Sebastien
Administrateur
Administrateur
 
Messages: 5504
Enregistré le: 14 Fév 2005 19:17
Localisation: LILLE

Re: Formule excel 2016

Messagepar ANTOINE64 » 21 Mar 2018 20:47

Bonsoir à tous,
J'ai rentré cette formule en H14 et une fenêtre me dit que j'ai rentré un nombre trop important d'arguments pour cette fonction, quelqu'un pourrait il m'aider à le résoudre:
=SI(ET(D7="";F7="";H7="";F6="");"";SI(ET(C6=AUJOURDHUI();D7+F7+H7=F6);H14=C6+3;"");SI(ET(C6>AUJOURDHUI();D7+F7+H7=F6);H14=D8+3;""))))
Explication:
Si D7,F7,H7,F6 sont vide alors H14 est vide.
Si C6=AUJOURDHUI et que D7+F7+H7=F6 alors H14=C6+3
Si C6>AUJOURDHUI et que D7+F7+H7=F6 alors H14=D8+3 sinon H14 est vide.
Dans l'attente de vous lire
Cordialement
ANTOINE64
No0b
No0b
 
Messages: 5
Enregistré le: 19 Mar 2018 11:35

Re: Formule excel 2016

Messagepar Sebastien » 21 Mar 2018 23:10

Bonjour,

Les formules ne sont pas imbriquées correctement. Il y a un argument de trop là :
H14=C6+3;"");SI(ET

Essayez avec cette formule :
Code: Tout sélectionner
=SI(ET(D7="";F7="";H7="";F6="");"";SI(ET(C6=AUJOURDHUI();D7+F7+H7=F6);C6+3;SI(ET(C6>AUJOURDHUI();D7+F7+H7=F6);D8+3;"")))


@+
Image
Avatar de l’utilisateur
Sebastien
Administrateur
Administrateur
 
Messages: 5504
Enregistré le: 14 Fév 2005 19:17
Localisation: LILLE

Re: Formule excel 2016

Messagepar ANTOINE64 » 22 Mar 2018 10:31

Bonjour à tous,
J'ai enfin trouver la formule qui me convient
=SI(ESTERREUR(SI(ET(D7="";F7="";H7="";F6="");"";SI(D7+H7=F6;C6+3;SI(D7+F7+H7=F6;D8+3;""))));"";SI(D7+H7=F6;C6+3;SI(D7+F7+H7=F6;D8+3;"")))
merci a tous pour le temps passé à résoudre mon probléme
Cordialement
ANTOINE64
No0b
No0b
 
Messages: 5
Enregistré le: 19 Mar 2018 11:35


Retourner vers Forum d'entraide : Bureautique

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 6 invités

  • Publicité
cron