• Publicité

formule

Dans ce forum, vous pouvez poser toutes vos questions concernant l'utilisation de logiciels de bureautique (Microsoft Office, Open Office, etc.)

Modérateurs: Sebastien, Stéphane, Christophe

formule

Messagepar pat60190 » 27 Aoû 2020 13:51

Bonjour je me fais un arbre généalogique et j’ai un problème que je n’arrive pas à résoudre une âme charitable pourrait-elle m’aider SVP
J’ai dans ma cellule A1 ma formule =ANNEE(AUJOURDHUI())
Dans ma cellule C3 je rentre la date de naissance
Dans la cellule D3 la date de décès
Dans la cellule C17 la formule =(A1-C3) cela est bon, mais comment figé ce résultat quand la date de décès est rentré
La je sèche on peut m’aidez par avance merci

:yeux:
pat60190
No0b
No0b
 
Messages: 1
Enregistré le: 27 Aoû 2020 13:31

Re: formule

Messagepar Sebastien » 27 Aoû 2020 19:12

Bonjour,

Il faut faire deux formules et ajouter une condition pour utiliser l'une ou l'autre selon qu'on ait une date de décès ou pas. Cela donnerait quelque chose comme ça :
S'il n'y a pas de date de décès de renseignée, alors on fait le calcul A, sinon on fait le calcul B.

On peut utiliser une formule SI (voir cette page pour des exemples : Les fonctions logiques : SI) et un test ESTVIDE sur la cellule de la date de décès.

Voici comment rédiger la formule :
Code: Tout sélectionner
=SI(ESTVIDE(D3);A1-C3;D3-C3)


Par contre, si votre objectif est de calculer un age, je vous recommande la fonction datedif qui permet de le faire. Voir cette page : Les fonctions Date et Heure : DATEDIF

Avec la condition sur la date de décès, ça donnerait :
Code: Tout sélectionner
=SI(ESTVIDE(D3);DATEDIF(C3;AUJOURDHUI();"y");DATEDIF(C3;D3;"y"))


@+
Image
Avatar de l’utilisateur
Sebastien
Administrateur
Administrateur
 
Messages: 5561
Enregistré le: 14 Fév 2005 19:17
Localisation: LILLE


Retourner vers Forum d'entraide : Bureautique

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité

  • Publicité