• Publicité

aide sur formule excel

Postez ici vos questions et(ou) vos solutions ayant pour thème les logiciels ou l'informatique en général. Vous pouvez également poser ici les questions informatiques qui n'auraient pas leur place dans les autres sections de notre forum d'entraide.

Modérateurs: Sebastien, Stéphane, Christophe

aide sur formule excel

Messagepar cbronze3 » 14 Juin 2022 08:37

Bonjour,

Je suis sur un tableau excel et je bloque sur une formule :
Pour faire simple, j'ai 2 onglets ; dans le 1er onglet A j'ai 2 colonnes la 1ère avec des numéros de positions et la 2ème avec les montants correspondants aux positions
Dans le 2ème onglet B, 1 colonne avec des numéros de positions
Je veux faire une formule dans une nouvelle colonne de l'onglet B : si le N°de position de l'onglet B correspond au n° de l'onglet A alors inscrit le montant correspondant , sinon ne met rien ou 0
Pouvez-vous m'aider et m'indiquer la formule adaptée
Merci
cbronze3
No0b
No0b
 
Messages: 2
Enregistré le: 14 Juin 2022 08:27

Re: aide sur formule excel

Messagepar Sebastien » 14 Juin 2022 21:04

Bonjour,
Je suis sur un tableau excel et je bloque sur une formule :
Pour faire simple, j'ai 2 onglets ; dans le 1er onglet A j'ai 2 colonnes la 1ère avec des numéros de positions et la 2ème avec les montants correspondants aux positions
Dans le 2ème onglet B, 1 colonne avec des numéros de positions
Je veux faire une formule dans une nouvelle colonne de l'onglet B : si le N°de position de l'onglet B correspond au n° de l'onglet A alors inscrit le montant correspondant , sinon ne met rien ou 0

Vous pouvez utiliser une formule RECHERCHEV afin d'aller chercher des valeurs dans l'onglet A et les afficher dans l'onglet B en face des numéros de positions correspondants.
Lien vers des explications sur la formule : https://www.astucesinternet.com/modules ... ?itemid=22

Par exemple : dans votre onglet B, dans la cellule où vous voulez afficher le montant présent dans l'autre feuille.
=RECHERCHEV(A2;BASE;2;FAUX)
A2 = la cellule contenant le numéro de position saisi dans votre onglet B et que vous voulez rechercher dans l'autre feuille.
BASE = la plage de données où se trouve les données dans l'onglet A (l'endroit où on va chercher les valeurs). Il est possible de saisir des plages du type A1:B20 ou des noms de plages.
2 = la colonne où se trouve la valeur à afficher
FAUX = on cherche une valeur exacte.

C'est un exemple, il faut l'adapter à votre cas.

Pour éviter d'afficher un #N/A en cas de valeur non trouvée, il faut combiner avec deux autres formules.

Si je reprends la formule ci-dessus RECHERCHEV(A2;BASE;2;FAUX)
ça donnerait :

=SI(ESTERREUR(RECHERCHEV(A2;BASE;2;FAUX));"";RECHERCHEV(A2;BASE;2;FAUX))
en cas d'erreur (valeur non retrouvée), ça affichera du vide.

@+
Image
Avatar de l’utilisateur
Sebastien
Administrateur
Administrateur
 
Messages: 5561
Enregistré le: 14 Fév 2005 19:17
Localisation: LILLE

Re: aide sur formule excel

Messagepar cbronze3 » 15 Juin 2022 11:41

Super !!

Merci beaucoup ! ça m'a bien aidé :-)
cbronze3
No0b
No0b
 
Messages: 2
Enregistré le: 14 Juin 2022 08:27

Re: aide sur formule excel

Messagepar Clement52 » 21 Juin 2022 15:48

Hello,

Merci bien @Sebastien pour cette astuce, je commence à peine à utiliser excel et ces infos me seront d'une grande utilité pour plus tard.


<Edité par Sébastien> Lien supprimé non conforme à notre charte
Modifié en dernier par Sebastien le 24 Juil 2022 17:00, modifié 1 fois.
Raison: Lien non conforme à la charte
Clement52
No0b
No0b
 
Messages: 1
Enregistré le: 21 Juin 2022 15:43
Localisation: Marseille


Retourner vers Forum d'entraide informatique

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 5 invités

  • Publicité
cron