Recherche
Publicités
Question aléatoire
Comment créer un point de restauration dans Windows Vista ?

Publicités
Qui est en ligne
12 Personne(s) en ligne (2 Personne(s) connectée(s) sur Fiches Pratiques)

Utilisateurs: 0
Invités: 12

plus...
SmartSection is developed by The SmartFactory (http://www.smartfactory.ca), a division of INBOX Solutions (http://inboxinternational.com)
Fiches Pratiques > Bureautique > EXCEL : Les fonctions utiles > Les fonctions logiques : OU
Les fonctions logiques : OU
Publié par Sebastien le 23-04-2006 (260431 lus)
Description : Renvoie la valeur VRAI si une des conditions est VRAI et la valeur FAUX si toutes les conditions sont fausses.

Syntaxe : OU(valeur_logique1;valeur_logique2,...)

valeur_logique1,valeur_logique2, ... représentent les conditions à remplir. Il est possible de saisir jusqu'à 30 conditions.

Exemple :
Soit un tableau présentant les résultats de trois épreuves. Nous allons vérifier que l'une des notes est supérieure ou égale à 16 ou que la moyenne soit supérieure ou égale à 14.
La colonne état affichera VRAI si l'une des conditions est remplie et FAUX si aucune des conditions n'est remplie.

Aperçu :
Exemple tableau fonction OU

Les critères seront (pour la ligne 3) :
valeur_logique1 : C3>=16
valeur_logique2 : D3>=16
valeur_logique3 : E3>=16
valeur_logique4 : F3>=14

La formule sera :
=OU(C3>=16;D3>=16;E3>=16;F3>=14)


La fonction OU s'utilise généralement imbriquée dans une autre fonction logique. Nous allons donc refaire un exemple en utilisant la fonction OU imbriquée dans la fonction SI.

Exemple :
L'objectif est d'afficher OK si l'une des conditions est remplie ou d'afficher ECHEC si aucune des conditions n'est remplie.

Aperçu :
Exemple tableau fonction imbriquée SI OU

Les critères seront (pour la ligne 3) :
test_logique : OU(C3>=16;D3>=16;E3>=16;F3>=14) (cela signifie C3 supérieur ou égal à 16 OU D3 supérieur ou égal à 16 OU E3 supérieur ou égal à 16 OU F3 supérieur ou égal à 14 )
valeur_si_vrai : OK
valeur_si_faux : ECHEC

=SI(OU(C3>=16;D3>=16;E3>=16;F3>=14);"OK";"ECHEC")


Exemple de formule avec trois fonctions logiques imbriquées :
Pour ce dernier exemple, nous allons créer une formule imbriquant la fonction SI, la fonction ET ainsi que la fonction OU.
L'objectif est d'afficher OK si la moyenne est supérieure ou égale à 10.
Si la moyenne est comprise entre 8 et 10 mais que l'une des notes est supérieure à 18, nous afficherons OK également.
Si aucune des conditions n'est remplie, nous afficherons ECHEC.

Aperçu du tableau :
Imbrication de fonctions SI, ET, OU

La formule sera :
=SI(F3>=10;"OK";SI(ET(OU(C3>=18;D3>=18;E3>=18);F3>8);"OK";"ECHEC"))

Test logique de la fonction SI : F3>=10
valeur_si_vrai : OK
valeur_si_faux : Seconde formule

Seconde formule : SI(ET(OU(C3>=18;D3>=18;E3>=18);F3>8);"OK";"ECHEC")
Test logique de la fonction SI : ET(OU(C3>=18;D3>=18;E3>=18);F3>8)
valeur_si_vrai : OK
valeur_si_faux : ECHEC

Autres articles dans cette catégorie Date de publication clics
Les fonctions Informations : ESTERREUR
10-03-2014
106094
Les fonctions Informations : EST.PAIR
20-02-2014
16437
Les fonctions Informations : EST.IMPAIR
20-02-2014
12768
Les fonctions Math et Trigo : ARRONDI.AU.MULTIPLE
20-02-2014
19298
Les fonctions Math et Trigo : PLANCHER
10-10-2012
20561
Les fonctions Math et Trigo : PLAFOND
10-10-2012
14824
Les fonctions Date et Heure : DATE
06-09-2010
76203
Les fonctions Date et Heure : DATEVAL
06-09-2010
63986
Les fonctions Date et Heure : DATEDIF
14-09-2008
119516
Les fonctions Recherche et Matrices : DECALER
11-08-2007
95823
Les fonctions Math et Trigo : MOD
16-05-2007
39512
Les fonctions Math et Trigo : ENT
16-05-2007
36002
Les fonctions statistiques : PETITE.VALEUR
29-01-2007
75492
Les fonctions statistiques : GRANDE.VALEUR
29-01-2007
74970
Les fonctions Math et Trigo : TRONQUE
27-01-2007
35474
Les fonctions statistiques : FREQUENCE
23-01-2007
226099
Les fonctions statistiques : NB.SI
07-10-2006
177223
Les fonctions statistiques : NBVAL
07-10-2006
144376
Les fonctions statistiques : NB.VIDE
07-10-2006
46304
Les fonctions statistiques : NB
07-10-2006
63780
Les fonctions mathématiques : SOMME.SI
05-10-2006
130092
Les fonctions Date et Heure : ANNEE
04-10-2006
51214
Les fonctions recherche et matrices : LIGNE
27-09-2006
69954
Les fonctions Math et Trigo : ABS
11-09-2006
26762
Les fonctions date et heure : AUJOURDHUI
11-09-2006
93385
Les fonctions Math et Trigo : ARRONDI
04-09-2006
58359
Les fonctions Math et Trigo : SOMMEPROD
27-08-2006
80867
Les fonctions textes : TEXTE
03-08-2006
126233
Les fonctions textes : SUPPRESPACE
03-08-2006
46813
Les fonctions Math et Trigo : ROMAIN
23-07-2006
210083
Les fonctions textes : CNUM
01-07-2006
77407
Les fonctions textes : REMPLACER
01-07-2006
106764
Les fonctions textes : SUBSTITUE
27-06-2006
88415
Les fonctions Recherche et Matrices : RECHERCHEV
10-06-2006
296695
Les fonctions textes : CHERCHE
03-06-2006
213465
Les fonctions textes : NBCAR
29-05-2006
72282
Les fonctions statistiques : RANG
29-05-2006
98372
Les fonctions Recherche et Matrices : EQUIV
25-05-2006
117932
Les fonctions Recherche et Matrices : INDEX
25-05-2006
93434
Les fonctions statistiques : MAX
23-05-2006
26701
Les fonctions statistiques : MIN
23-05-2006
17364
Les fonctions textes : MINUSCULE
20-05-2006
24684
Les fonctions textes : MAJUSCULE
20-05-2006
25976
Les fonctions textes : NOMPROPRE
19-05-2006
31305
Les fonctions mathématiques : SOUS TOTAL
30-04-2006
127363
Les fonctions mathématiques : SOMME
26-04-2006
31481
Les fonctions statistiques : MOYENNE
26-04-2006
39237
Les fonctions statistiques : MOYENNE REDUITE
26-04-2006
52455
Les fonctions textes : CONCATENER
23-04-2006
148649
Les fonctions textes : DROITE
23-04-2006
51245
Les fonctions textes : STXT
23-04-2006
123128
Les fonctions textes : GAUCHE
23-04-2006
74688
Les fonctions logiques : OU
23-04-2006
260432
Les fonctions logiques : ET
23-04-2006
96760
Les fonctions logiques : SI
23-04-2006
113735
Les commentaires appartiennent à leurs auteurs. Nous ne sommes pas responsables de leur contenu.
Posté Commentaire en débat
Publicités