Recherche
Publicités
Question aléatoire
Comment définir une adresse IP fixe dans Windows Vista ?

Publicités
Qui est en ligne
15 Personne(s) en ligne (3 Personne(s) connectée(s) sur Fiches Pratiques)

Utilisateurs: 0
Invités: 15

plus...
SmartSection is developed by The SmartFactory (http://www.smartfactory.ca), a division of INBOX Solutions (http://inboxinternational.com)
Fiches Pratiques > Bureautique > EXCEL : Les fonctions utiles > Les fonctions Informations : ESTERREUR
Les fonctions Informations : ESTERREUR
Publié par Sebastien le 10-03-2014 (62541 lus)
Descriptif : Permet de tester une valeur afin de vérifier si elle correspond à une erreur. La fonction renvoie VRAI si la valeur testée correspond à une erreur, et FAUX quand la valeur testée n'en contient pas.

Syntaxe : ESTERREUR(valeur)
  • valeur : Argument correspondant à la valeur à tester.
Note : Les codes d'erreurs couverts par cette fonction sont : #N/A, #VALEUR!, #REF!, #DIV/0!, #NOMBRE!, #NOM? et #NUL!.

Remarque : L'intérêt de cette fonction et que l'on peut la combiner avec une fonction SI, afin de pouvoir modifier le résultat d'une cellule lorsqu'elle contient une erreur.

Exemple :
Soit un tableau listant les notes ainsi que la moyenne obtenues par des candidats. Tant que les cellules de notes ne contiennent pas de valeur, la formule retourne une erreur #DIV/0!.

Aperçu :
Excel : ESTERREUR

La fonction ESTERREUR, combinée à une fonction SI, va nous permettre d'afficher du vide à la place du code d'erreur.

Les critères seront (pour la ligne B8) :
test_logique : ESTERREUR(MOYENNE(B3:B7))
valeur_si_vrai : ""
valeur_si_faux : MOYENNE(B3:B7)

La formule sera (pour la cellule B8) :
=SI(ESTERREUR(MOYENNE(B3:B7));"";MOYENNE(B3:B7))

Aperçu du résultat :
Excel : ESTERREUR

La cellule affichera du vide lorsque la moyenne renverra une erreur, et le résultat correct si aucune erreur n'est détectée.


Autre exemple d'utilisation de cette fonction :
Lors de l'utilisation de la fonction RECHERCHEV, si une valeur n'est pas trouvée dans la table de référence, la fonction retourne une erreur #N/A. La fonction ESTERREUR, combinée à une fonction SI, permet d'éviter l'affichage de codes d'erreur.

Exemple :
Excel : ESTERREUR

Aperçu :
Excel : ESTERREUR

Les critères seront (pour la ligne B3) :
test_logique : ESTERREUR(RECHERCHEV(A3;$E$3:$F$7;2;0))
valeur_si_vrai : "Inconnu"
valeur_si_faux : RECHERCHEV(A3;$E$3:$F$7;2;0)

La formule sera (pour la cellule B3) :
=SI(ESTERREUR(RECHERCHEV(A3;$E$3:$F$7;2;0));"Inconnu";RECHERCHEV(A3;$E$3:$F$7;2;0))

Aperçu du résultat :
Excel : ESTERREUR

La cellule affichera "Inconnu" lorsque la valeur recherchée sera non trouvée par RECHERCHEV.
  Imprimer cet article Envoyer cet article

Autres articles dans cette catégorie Date de publication clics
Les fonctions Informations : ESTERREUR
10-03-2014
62542
Les fonctions Informations : EST.PAIR
20-02-2014
11020
Les fonctions Informations : EST.IMPAIR
20-02-2014
9236
Les fonctions Math et Trigo : ARRONDI.AU.MULTIPLE
20-02-2014
14772
Les fonctions Math et Trigo : PLANCHER
10-10-2012
17651
Les fonctions Math et Trigo : PLAFOND
10-10-2012
11749
Les fonctions Date et Heure : DATE
06-09-2010
69043
Les fonctions Date et Heure : DATEVAL
06-09-2010
55277
Les fonctions Date et Heure : DATEDIF
14-09-2008
108128
Les fonctions Recherche et Matrices : DECALER
11-08-2007
89689
Les fonctions Math et Trigo : MOD
16-05-2007
35951
Les fonctions Math et Trigo : ENT
16-05-2007
32421
Les fonctions statistiques : PETITE.VALEUR
29-01-2007
66803
Les fonctions statistiques : GRANDE.VALEUR
29-01-2007
68404
Les fonctions Math et Trigo : TRONQUE
27-01-2007
31841
Les fonctions statistiques : FREQUENCE
23-01-2007
194983
Les fonctions statistiques : NB.SI
07-10-2006
165766
Les fonctions statistiques : NBVAL
07-10-2006
137008
Les fonctions statistiques : NB.VIDE
07-10-2006
42974
Les fonctions statistiques : NB
07-10-2006
59954
Les fonctions mathématiques : SOMME.SI
05-10-2006
121989
Les fonctions Date et Heure : ANNEE
04-10-2006
46147
Les fonctions recherche et matrices : LIGNE
27-09-2006
63339
Les fonctions Math et Trigo : ABS
11-09-2006
23556
Les fonctions date et heure : AUJOURDHUI
11-09-2006
85802
Les fonctions Math et Trigo : ARRONDI
04-09-2006
51691
Les fonctions Math et Trigo : SOMMEPROD
27-08-2006
74744
Les fonctions textes : TEXTE
03-08-2006
120682
Les fonctions textes : SUPPRESPACE
03-08-2006
42692
Les fonctions Math et Trigo : ROMAIN
23-07-2006
204633
Les fonctions textes : CNUM
01-07-2006
67285
Les fonctions textes : REMPLACER
01-07-2006
101550
Les fonctions textes : SUBSTITUE
27-06-2006
73613
Les fonctions Recherche et Matrices : RECHERCHEV
10-06-2006
266690
Les fonctions textes : CHERCHE
03-06-2006
198817
Les fonctions textes : NBCAR
29-05-2006
65754
Les fonctions statistiques : RANG
29-05-2006
88900
Les fonctions Recherche et Matrices : EQUIV
25-05-2006
112242
Les fonctions Recherche et Matrices : INDEX
25-05-2006
88612
Les fonctions statistiques : MAX
23-05-2006
23885
Les fonctions statistiques : MIN
23-05-2006
15089
Les fonctions textes : MINUSCULE
20-05-2006
22108
Les fonctions textes : MAJUSCULE
20-05-2006
23592
Les fonctions textes : NOMPROPRE
19-05-2006
28524
Les fonctions mathématiques : SOUS TOTAL
30-04-2006
114871
Les fonctions mathématiques : SOMME
26-04-2006
28708
Les fonctions statistiques : MOYENNE
26-04-2006
34543
Les fonctions statistiques : MOYENNE REDUITE
26-04-2006
45351
Les fonctions textes : CONCATENER
23-04-2006
142864
Les fonctions textes : DROITE
23-04-2006
47652
Les fonctions textes : STXT
23-04-2006
112161
Les fonctions textes : GAUCHE
23-04-2006
70522
Les fonctions logiques : OU
23-04-2006
243324
Les fonctions logiques : ET
23-04-2006
89305
Les fonctions logiques : SI
23-04-2006
103432
Les commentaires appartiennent à leurs auteurs. Nous ne sommes pas responsables de leur contenu.
Posté Commentaire en débat
Publicités