Recherche
Publicités
Question aléatoire
Comment enregistrer les logins et les mots de passe dans Internet Explorer ?

Publicités
Qui est en ligne
18 Personne(s) en ligne (4 Personne(s) connectée(s) sur Fiches Pratiques)

Utilisateurs: 0
Invités: 18

plus...
SmartSection is developed by The SmartFactory (http://www.smartfactory.ca), a division of INBOX Solutions (http://inboxinternational.com)
Fiches Pratiques > Bureautique > EXCEL : Les fonctions utiles > Les fonctions Informations : ESTERREUR
Les fonctions Informations : ESTERREUR
Publié par Sebastien le 10-03-2014 (67136 lus)
Descriptif : Permet de tester une valeur afin de vérifier si elle correspond à une erreur. La fonction renvoie VRAI si la valeur testée correspond à une erreur, et FAUX quand la valeur testée n'en contient pas.

Syntaxe : ESTERREUR(valeur)
  • valeur : Argument correspondant à la valeur à tester.
Note : Les codes d'erreurs couverts par cette fonction sont : #N/A, #VALEUR!, #REF!, #DIV/0!, #NOMBRE!, #NOM? et #NUL!.

Remarque : L'intérêt de cette fonction et que l'on peut la combiner avec une fonction SI, afin de pouvoir modifier le résultat d'une cellule lorsqu'elle contient une erreur.

Exemple :
Soit un tableau listant les notes ainsi que la moyenne obtenues par des candidats. Tant que les cellules de notes ne contiennent pas de valeur, la formule retourne une erreur #DIV/0!.

Aperçu :
Excel : ESTERREUR

La fonction ESTERREUR, combinée à une fonction SI, va nous permettre d'afficher du vide à la place du code d'erreur.

Les critères seront (pour la ligne B8) :
test_logique : ESTERREUR(MOYENNE(B3:B7))
valeur_si_vrai : ""
valeur_si_faux : MOYENNE(B3:B7)

La formule sera (pour la cellule B8) :
=SI(ESTERREUR(MOYENNE(B3:B7));"";MOYENNE(B3:B7))

Aperçu du résultat :
Excel : ESTERREUR

La cellule affichera du vide lorsque la moyenne renverra une erreur, et le résultat correct si aucune erreur n'est détectée.


Autre exemple d'utilisation de cette fonction :
Lors de l'utilisation de la fonction RECHERCHEV, si une valeur n'est pas trouvée dans la table de référence, la fonction retourne une erreur #N/A. La fonction ESTERREUR, combinée à une fonction SI, permet d'éviter l'affichage de codes d'erreur.

Exemple :
Excel : ESTERREUR

Aperçu :
Excel : ESTERREUR

Les critères seront (pour la ligne B3) :
test_logique : ESTERREUR(RECHERCHEV(A3;$E$3:$F$7;2;0))
valeur_si_vrai : "Inconnu"
valeur_si_faux : RECHERCHEV(A3;$E$3:$F$7;2;0)

La formule sera (pour la cellule B3) :
=SI(ESTERREUR(RECHERCHEV(A3;$E$3:$F$7;2;0));"Inconnu";RECHERCHEV(A3;$E$3:$F$7;2;0))

Aperçu du résultat :
Excel : ESTERREUR

La cellule affichera "Inconnu" lorsque la valeur recherchée sera non trouvée par RECHERCHEV.
  Imprimer cet article Envoyer cet article

Autres articles dans cette catégorie Date de publication clics
Les fonctions Informations : ESTERREUR
10-03-2014
67137
Les fonctions Informations : EST.PAIR
20-02-2014
11581
Les fonctions Informations : EST.IMPAIR
20-02-2014
9707
Les fonctions Math et Trigo : ARRONDI.AU.MULTIPLE
20-02-2014
15368
Les fonctions Math et Trigo : PLANCHER
10-10-2012
18057
Les fonctions Math et Trigo : PLAFOND
10-10-2012
12115
Les fonctions Date et Heure : DATE
06-09-2010
70138
Les fonctions Date et Heure : DATEVAL
06-09-2010
56326
Les fonctions Date et Heure : DATEDIF
14-09-2008
109714
Les fonctions Recherche et Matrices : DECALER
11-08-2007
90541
Les fonctions Math et Trigo : MOD
16-05-2007
36332
Les fonctions Math et Trigo : ENT
16-05-2007
32833
Les fonctions statistiques : PETITE.VALEUR
29-01-2007
67669
Les fonctions statistiques : GRANDE.VALEUR
29-01-2007
69147
Les fonctions Math et Trigo : TRONQUE
27-01-2007
32295
Les fonctions statistiques : FREQUENCE
23-01-2007
198989
Les fonctions statistiques : NB.SI
07-10-2006
167436
Les fonctions statistiques : NBVAL
07-10-2006
137700
Les fonctions statistiques : NB.VIDE
07-10-2006
43344
Les fonctions statistiques : NB
07-10-2006
60432
Les fonctions mathématiques : SOMME.SI
05-10-2006
123522
Les fonctions Date et Heure : ANNEE
04-10-2006
46781
Les fonctions recherche et matrices : LIGNE
27-09-2006
64261
Les fonctions Math et Trigo : ABS
11-09-2006
24026
Les fonctions date et heure : AUJOURDHUI
11-09-2006
86711
Les fonctions Math et Trigo : ARRONDI
04-09-2006
52288
Les fonctions Math et Trigo : SOMMEPROD
27-08-2006
75418
Les fonctions textes : TEXTE
03-08-2006
121613
Les fonctions textes : SUPPRESPACE
03-08-2006
43158
Les fonctions Math et Trigo : ROMAIN
23-07-2006
205190
Les fonctions textes : CNUM
01-07-2006
68234
Les fonctions textes : REMPLACER
01-07-2006
102189
Les fonctions textes : SUBSTITUE
27-06-2006
75573
Les fonctions Recherche et Matrices : RECHERCHEV
10-06-2006
271772
Les fonctions textes : CHERCHE
03-06-2006
200740
Les fonctions textes : NBCAR
29-05-2006
66449
Les fonctions statistiques : RANG
29-05-2006
90160
Les fonctions Recherche et Matrices : EQUIV
25-05-2006
113042
Les fonctions Recherche et Matrices : INDEX
25-05-2006
89199
Les fonctions statistiques : MAX
23-05-2006
24196
Les fonctions statistiques : MIN
23-05-2006
15364
Les fonctions textes : MINUSCULE
20-05-2006
22376
Les fonctions textes : MAJUSCULE
20-05-2006
23906
Les fonctions textes : NOMPROPRE
19-05-2006
28833
Les fonctions mathématiques : SOUS TOTAL
30-04-2006
116342
Les fonctions mathématiques : SOMME
26-04-2006
29078
Les fonctions statistiques : MOYENNE
26-04-2006
35147
Les fonctions statistiques : MOYENNE REDUITE
26-04-2006
46256
Les fonctions textes : CONCATENER
23-04-2006
143504
Les fonctions textes : DROITE
23-04-2006
48027
Les fonctions textes : STXT
23-04-2006
113509
Les fonctions textes : GAUCHE
23-04-2006
70912
Les fonctions logiques : OU
23-04-2006
246222
Les fonctions logiques : ET
23-04-2006
90627
Les fonctions logiques : SI
23-04-2006
104773
Les commentaires appartiennent à leurs auteurs. Nous ne sommes pas responsables de leur contenu.
Posté Commentaire en débat
Publicités