Recherche
Publicités
Question aléatoire
Comment ajouter un compte de courrier dans Windows Mail ?

Publicités
Qui est en ligne
12 Personne(s) en ligne (2 Personne(s) connectée(s) sur Fiches Pratiques)

Utilisateurs: 0
Invités: 12

plus...
SmartSection is developed by The SmartFactory (http://www.smartfactory.ca), a division of INBOX Solutions (http://inboxinternational.com)
Fiches Pratiques > Bureautique > EXCEL : Les fonctions utiles > Les fonctions Informations : ESTERREUR
Les fonctions Informations : ESTERREUR
Publié par Sebastien le 10-03-2014 (71814 lus)
Descriptif : Permet de tester une valeur afin de vérifier si elle correspond à une erreur. La fonction renvoie VRAI si la valeur testée correspond à une erreur, et FAUX quand la valeur testée n'en contient pas.

Syntaxe : ESTERREUR(valeur)
  • valeur : Argument correspondant à la valeur à tester.
Note : Les codes d'erreurs couverts par cette fonction sont : #N/A, #VALEUR!, #REF!, #DIV/0!, #NOMBRE!, #NOM? et #NUL!.

Remarque : L'intérêt de cette fonction et que l'on peut la combiner avec une fonction SI, afin de pouvoir modifier le résultat d'une cellule lorsqu'elle contient une erreur.

Exemple :
Soit un tableau listant les notes ainsi que la moyenne obtenues par des candidats. Tant que les cellules de notes ne contiennent pas de valeur, la formule retourne une erreur #DIV/0!.

Aperçu :
Excel : ESTERREUR

La fonction ESTERREUR, combinée à une fonction SI, va nous permettre d'afficher du vide à la place du code d'erreur.

Les critères seront (pour la ligne B8) :
test_logique : ESTERREUR(MOYENNE(B3:B7))
valeur_si_vrai : ""
valeur_si_faux : MOYENNE(B3:B7)

La formule sera (pour la cellule B8) :
=SI(ESTERREUR(MOYENNE(B3:B7));"";MOYENNE(B3:B7))

Aperçu du résultat :
Excel : ESTERREUR

La cellule affichera du vide lorsque la moyenne renverra une erreur, et le résultat correct si aucune erreur n'est détectée.


Autre exemple d'utilisation de cette fonction :
Lors de l'utilisation de la fonction RECHERCHEV, si une valeur n'est pas trouvée dans la table de référence, la fonction retourne une erreur #N/A. La fonction ESTERREUR, combinée à une fonction SI, permet d'éviter l'affichage de codes d'erreur.

Exemple :
Excel : ESTERREUR

Aperçu :
Excel : ESTERREUR

Les critères seront (pour la ligne B3) :
test_logique : ESTERREUR(RECHERCHEV(A3;$E$3:$F$7;2;0))
valeur_si_vrai : "Inconnu"
valeur_si_faux : RECHERCHEV(A3;$E$3:$F$7;2;0)

La formule sera (pour la cellule B3) :
=SI(ESTERREUR(RECHERCHEV(A3;$E$3:$F$7;2;0));"Inconnu";RECHERCHEV(A3;$E$3:$F$7;2;0))

Aperçu du résultat :
Excel : ESTERREUR

La cellule affichera "Inconnu" lorsque la valeur recherchée sera non trouvée par RECHERCHEV.
  Imprimer cet article Envoyer cet article

Autres articles dans cette catégorie Date de publication clics
Les fonctions Informations : ESTERREUR
10-03-2014
71815
Les fonctions Informations : EST.PAIR
20-02-2014
12131
Les fonctions Informations : EST.IMPAIR
20-02-2014
10200
Les fonctions Math et Trigo : ARRONDI.AU.MULTIPLE
20-02-2014
15942
Les fonctions Math et Trigo : PLANCHER
10-10-2012
18418
Les fonctions Math et Trigo : PLAFOND
10-10-2012
12520
Les fonctions Date et Heure : DATE
06-09-2010
71219
Les fonctions Date et Heure : DATEVAL
06-09-2010
57338
Les fonctions Date et Heure : DATEDIF
14-09-2008
111272
Les fonctions Recherche et Matrices : DECALER
11-08-2007
91418
Les fonctions Math et Trigo : MOD
16-05-2007
36753
Les fonctions Math et Trigo : ENT
16-05-2007
33286
Les fonctions statistiques : PETITE.VALEUR
29-01-2007
68610
Les fonctions statistiques : GRANDE.VALEUR
29-01-2007
69946
Les fonctions Math et Trigo : TRONQUE
27-01-2007
32790
Les fonctions statistiques : FREQUENCE
23-01-2007
202687
Les fonctions statistiques : NB.SI
07-10-2006
168910
Les fonctions statistiques : NBVAL
07-10-2006
138539
Les fonctions statistiques : NB.VIDE
07-10-2006
43715
Les fonctions statistiques : NB
07-10-2006
60978
Les fonctions mathématiques : SOMME.SI
05-10-2006
124962
Les fonctions Date et Heure : ANNEE
04-10-2006
47478
Les fonctions recherche et matrices : LIGNE
27-09-2006
65163
Les fonctions Math et Trigo : ABS
11-09-2006
24526
Les fonctions date et heure : AUJOURDHUI
11-09-2006
87642
Les fonctions Math et Trigo : ARRONDI
04-09-2006
52987
Les fonctions Math et Trigo : SOMMEPROD
27-08-2006
76239
Les fonctions textes : TEXTE
03-08-2006
122470
Les fonctions textes : SUPPRESPACE
03-08-2006
43676
Les fonctions Math et Trigo : ROMAIN
23-07-2006
205887
Les fonctions textes : CNUM
01-07-2006
69226
Les fonctions textes : REMPLACER
01-07-2006
102970
Les fonctions textes : SUBSTITUE
27-06-2006
77899
Les fonctions Recherche et Matrices : RECHERCHEV
10-06-2006
275796
Les fonctions textes : CHERCHE
03-06-2006
202446
Les fonctions textes : NBCAR
29-05-2006
67279
Les fonctions statistiques : RANG
29-05-2006
91463
Les fonctions Recherche et Matrices : EQUIV
25-05-2006
113828
Les fonctions Recherche et Matrices : INDEX
25-05-2006
89811
Les fonctions statistiques : MAX
23-05-2006
24492
Les fonctions statistiques : MIN
23-05-2006
15641
Les fonctions textes : MINUSCULE
20-05-2006
22668
Les fonctions textes : MAJUSCULE
20-05-2006
24200
Les fonctions textes : NOMPROPRE
19-05-2006
29213
Les fonctions mathématiques : SOUS TOTAL
30-04-2006
117809
Les fonctions mathématiques : SOMME
26-04-2006
29449
Les fonctions statistiques : MOYENNE
26-04-2006
35808
Les fonctions statistiques : MOYENNE REDUITE
26-04-2006
47201
Les fonctions textes : CONCATENER
23-04-2006
144242
Les fonctions textes : DROITE
23-04-2006
48460
Les fonctions textes : STXT
23-04-2006
115000
Les fonctions textes : GAUCHE
23-04-2006
71413
Les fonctions logiques : OU
23-04-2006
249500
Les fonctions logiques : ET
23-04-2006
91798
Les fonctions logiques : SI
23-04-2006
105831
Les commentaires appartiennent à leurs auteurs. Nous ne sommes pas responsables de leur contenu.
Posté Commentaire en débat
Publicités