Recherche
Publicités
Question aléatoire
Comment modifier les alertes du centre de sécurité ?

Publicités
Qui est en ligne
5 Personne(s) en ligne (1 Personne(s) connectée(s) sur Fiches Pratiques)

Utilisateurs: 0
Invités: 5

plus...
SmartSection is developed by The SmartFactory (http://www.smartfactory.ca), a division of INBOX Solutions (http://inboxinternational.com)
Fiches Pratiques > Bureautique > EXCEL : Les fonctions utiles > Les fonctions Informations : ESTERREUR
Les fonctions Informations : ESTERREUR
Publié par Sebastien le 10-03-2014 (104416 lus)
Descriptif : Permet de tester une valeur afin de vérifier si elle correspond à une erreur. La fonction renvoie VRAI si la valeur testée correspond à une erreur, et FAUX quand la valeur testée n'en contient pas.

Syntaxe : ESTERREUR(valeur)
  • valeur : Argument correspondant à la valeur à tester.
Note : Les codes d'erreurs couverts par cette fonction sont : #N/A, #VALEUR!, #REF!, #DIV/0!, #NOMBRE!, #NOM? et #NUL!.

Remarque : L'intérêt de cette fonction et que l'on peut la combiner avec une fonction SI, afin de pouvoir modifier le résultat d'une cellule lorsqu'elle contient une erreur.

Exemple :
Soit un tableau listant les notes ainsi que la moyenne obtenues par des candidats. Tant que les cellules de notes ne contiennent pas de valeur, la formule retourne une erreur #DIV/0!.

Aperçu :
Excel : ESTERREUR

La fonction ESTERREUR, combinée à une fonction SI, va nous permettre d'afficher du vide à la place du code d'erreur.

Les critères seront (pour la ligne B8) :
test_logique : ESTERREUR(MOYENNE(B3:B7))
valeur_si_vrai : ""
valeur_si_faux : MOYENNE(B3:B7)

La formule sera (pour la cellule B8) :
=SI(ESTERREUR(MOYENNE(B3:B7));"";MOYENNE(B3:B7))

Aperçu du résultat :
Excel : ESTERREUR

La cellule affichera du vide lorsque la moyenne renverra une erreur, et le résultat correct si aucune erreur n'est détectée.


Autre exemple d'utilisation de cette fonction :
Lors de l'utilisation de la fonction RECHERCHEV, si une valeur n'est pas trouvée dans la table de référence, la fonction retourne une erreur #N/A. La fonction ESTERREUR, combinée à une fonction SI, permet d'éviter l'affichage de codes d'erreur.

Exemple :
Excel : ESTERREUR

Aperçu :
Excel : ESTERREUR

Les critères seront (pour la ligne B3) :
test_logique : ESTERREUR(RECHERCHEV(A3;$E$3:$F$7;2;0))
valeur_si_vrai : "Inconnu"
valeur_si_faux : RECHERCHEV(A3;$E$3:$F$7;2;0)

La formule sera (pour la cellule B3) :
=SI(ESTERREUR(RECHERCHEV(A3;$E$3:$F$7;2;0));"Inconnu";RECHERCHEV(A3;$E$3:$F$7;2;0))

Aperçu du résultat :
Excel : ESTERREUR

La cellule affichera "Inconnu" lorsque la valeur recherchée sera non trouvée par RECHERCHEV.
  Imprimer cet article Envoyer cet article

Autres articles dans cette catégorie Date de publication clics
Les fonctions Informations : ESTERREUR
10-03-2014
104417
Les fonctions Informations : EST.PAIR
20-02-2014
16193
Les fonctions Informations : EST.IMPAIR
20-02-2014
12576
Les fonctions Math et Trigo : ARRONDI.AU.MULTIPLE
20-02-2014
18984
Les fonctions Math et Trigo : PLANCHER
10-10-2012
20470
Les fonctions Math et Trigo : PLAFOND
10-10-2012
14700
Les fonctions Date et Heure : DATE
06-09-2010
75944
Les fonctions Date et Heure : DATEVAL
06-09-2010
63760
Les fonctions Date et Heure : DATEDIF
14-09-2008
119088
Les fonctions Recherche et Matrices : DECALER
11-08-2007
95573
Les fonctions Math et Trigo : MOD
16-05-2007
39318
Les fonctions Math et Trigo : ENT
16-05-2007
35814
Les fonctions statistiques : PETITE.VALEUR
29-01-2007
75111
Les fonctions statistiques : GRANDE.VALEUR
29-01-2007
74607
Les fonctions Math et Trigo : TRONQUE
27-01-2007
35291
Les fonctions statistiques : FREQUENCE
23-01-2007
224577
Les fonctions statistiques : NB.SI
07-10-2006
176733
Les fonctions statistiques : NBVAL
07-10-2006
144109
Les fonctions statistiques : NB.VIDE
07-10-2006
46116
Les fonctions statistiques : NB
07-10-2006
63594
Les fonctions mathématiques : SOMME.SI
05-10-2006
129850
Les fonctions Date et Heure : ANNEE
04-10-2006
50977
Les fonctions recherche et matrices : LIGNE
27-09-2006
69664
Les fonctions Math et Trigo : ABS
11-09-2006
26615
Les fonctions date et heure : AUJOURDHUI
11-09-2006
92925
Les fonctions Math et Trigo : ARRONDI
04-09-2006
58044
Les fonctions Math et Trigo : SOMMEPROD
27-08-2006
80584
Les fonctions textes : TEXTE
03-08-2006
126020
Les fonctions textes : SUPPRESPACE
03-08-2006
46683
Les fonctions Math et Trigo : ROMAIN
23-07-2006
209861
Les fonctions textes : CNUM
01-07-2006
76984
Les fonctions textes : REMPLACER
01-07-2006
106590
Les fonctions textes : SUBSTITUE
27-06-2006
87892
Les fonctions Recherche et Matrices : RECHERCHEV
10-06-2006
295687
Les fonctions textes : CHERCHE
03-06-2006
212875
Les fonctions textes : NBCAR
29-05-2006
72013
Les fonctions statistiques : RANG
29-05-2006
97949
Les fonctions Recherche et Matrices : EQUIV
25-05-2006
117689
Les fonctions Recherche et Matrices : INDEX
25-05-2006
93174
Les fonctions statistiques : MAX
23-05-2006
26526
Les fonctions statistiques : MIN
23-05-2006
17239
Les fonctions textes : MINUSCULE
20-05-2006
24552
Les fonctions textes : MAJUSCULE
20-05-2006
25855
Les fonctions textes : NOMPROPRE
19-05-2006
31216
Les fonctions mathématiques : SOUS TOTAL
30-04-2006
126983
Les fonctions mathématiques : SOMME
26-04-2006
31327
Les fonctions statistiques : MOYENNE
26-04-2006
38998
Les fonctions statistiques : MOYENNE REDUITE
26-04-2006
52065
Les fonctions textes : CONCATENER
23-04-2006
148415
Les fonctions textes : DROITE
23-04-2006
50915
Les fonctions textes : STXT
23-04-2006
122668
Les fonctions textes : GAUCHE
23-04-2006
74344
Les fonctions logiques : OU
23-04-2006
259829
Les fonctions logiques : ET
23-04-2006
96513
Les fonctions logiques : SI
23-04-2006
113434
Les commentaires appartiennent à leurs auteurs. Nous ne sommes pas responsables de leur contenu.
Posté Commentaire en débat
Publicités