Recherche
Publicités
Question aléatoire
Comment modifier la taille maximale du dossier Temporary Internet Files ?

Publicités
Qui est en ligne
29 Personne(s) en ligne (9 Personne(s) connectée(s) sur Fiches Pratiques)

Utilisateurs: 0
Invités: 29

plus...
SmartSection is developed by The SmartFactory (http://www.smartfactory.ca), a division of INBOX Solutions (http://inboxinternational.com)
Fiches Pratiques > Bureautique > EXCEL : Les fonctions utiles > Les fonctions Informations : ESTERREUR
Les fonctions Informations : ESTERREUR
Publié par Sebastien le 10-03-2014 (95952 lus)
Descriptif : Permet de tester une valeur afin de vérifier si elle correspond à une erreur. La fonction renvoie VRAI si la valeur testée correspond à une erreur, et FAUX quand la valeur testée n'en contient pas.

Syntaxe : ESTERREUR(valeur)
  • valeur : Argument correspondant à la valeur à tester.
Note : Les codes d'erreurs couverts par cette fonction sont : #N/A, #VALEUR!, #REF!, #DIV/0!, #NOMBRE!, #NOM? et #NUL!.

Remarque : L'intérêt de cette fonction et que l'on peut la combiner avec une fonction SI, afin de pouvoir modifier le résultat d'une cellule lorsqu'elle contient une erreur.

Exemple :
Soit un tableau listant les notes ainsi que la moyenne obtenues par des candidats. Tant que les cellules de notes ne contiennent pas de valeur, la formule retourne une erreur #DIV/0!.

Aperçu :
Excel : ESTERREUR

La fonction ESTERREUR, combinée à une fonction SI, va nous permettre d'afficher du vide à la place du code d'erreur.

Les critères seront (pour la ligne B8) :
test_logique : ESTERREUR(MOYENNE(B3:B7))
valeur_si_vrai : ""
valeur_si_faux : MOYENNE(B3:B7)

La formule sera (pour la cellule B8) :
=SI(ESTERREUR(MOYENNE(B3:B7));"";MOYENNE(B3:B7))

Aperçu du résultat :
Excel : ESTERREUR

La cellule affichera du vide lorsque la moyenne renverra une erreur, et le résultat correct si aucune erreur n'est détectée.


Autre exemple d'utilisation de cette fonction :
Lors de l'utilisation de la fonction RECHERCHEV, si une valeur n'est pas trouvée dans la table de référence, la fonction retourne une erreur #N/A. La fonction ESTERREUR, combinée à une fonction SI, permet d'éviter l'affichage de codes d'erreur.

Exemple :
Excel : ESTERREUR

Aperçu :
Excel : ESTERREUR

Les critères seront (pour la ligne B3) :
test_logique : ESTERREUR(RECHERCHEV(A3;$E$3:$F$7;2;0))
valeur_si_vrai : "Inconnu"
valeur_si_faux : RECHERCHEV(A3;$E$3:$F$7;2;0)

La formule sera (pour la cellule B3) :
=SI(ESTERREUR(RECHERCHEV(A3;$E$3:$F$7;2;0));"Inconnu";RECHERCHEV(A3;$E$3:$F$7;2;0))

Aperçu du résultat :
Excel : ESTERREUR

La cellule affichera "Inconnu" lorsque la valeur recherchée sera non trouvée par RECHERCHEV.
  Imprimer cet article Envoyer cet article

Autres articles dans cette catégorie Date de publication clics
Les fonctions Informations : ESTERREUR
10-03-2014
95953
Les fonctions Informations : EST.PAIR
20-02-2014
14846
Les fonctions Informations : EST.IMPAIR
20-02-2014
11862
Les fonctions Math et Trigo : ARRONDI.AU.MULTIPLE
20-02-2014
18117
Les fonctions Math et Trigo : PLANCHER
10-10-2012
19977
Les fonctions Math et Trigo : PLAFOND
10-10-2012
14176
Les fonctions Date et Heure : DATE
06-09-2010
74794
Les fonctions Date et Heure : DATEVAL
06-09-2010
62086
Les fonctions Date et Heure : DATEDIF
14-09-2008
117334
Les fonctions Recherche et Matrices : DECALER
11-08-2007
94445
Les fonctions Math et Trigo : MOD
16-05-2007
38637
Les fonctions Math et Trigo : ENT
16-05-2007
35035
Les fonctions statistiques : PETITE.VALEUR
29-01-2007
73075
Les fonctions statistiques : GRANDE.VALEUR
29-01-2007
73259
Les fonctions Math et Trigo : TRONQUE
27-01-2007
34671
Les fonctions statistiques : FREQUENCE
23-01-2007
218985
Les fonctions statistiques : NB.SI
07-10-2006
174687
Les fonctions statistiques : NBVAL
07-10-2006
142850
Les fonctions statistiques : NB.VIDE
07-10-2006
45446
Les fonctions statistiques : NB
07-10-2006
62943
Les fonctions mathématiques : SOMME.SI
05-10-2006
128700
Les fonctions Date et Heure : ANNEE
04-10-2006
50043
Les fonctions recherche et matrices : LIGNE
27-09-2006
68264
Les fonctions Math et Trigo : ABS
11-09-2006
26114
Les fonctions date et heure : AUJOURDHUI
11-09-2006
91226
Les fonctions Math et Trigo : ARRONDI
04-09-2006
56366
Les fonctions Math et Trigo : SOMMEPROD
27-08-2006
79516
Les fonctions textes : TEXTE
03-08-2006
125192
Les fonctions textes : SUPPRESPACE
03-08-2006
45914
Les fonctions Math et Trigo : ROMAIN
23-07-2006
208874
Les fonctions textes : CNUM
01-07-2006
74375
Les fonctions textes : REMPLACER
01-07-2006
105990
Les fonctions textes : SUBSTITUE
27-06-2006
85411
Les fonctions Recherche et Matrices : RECHERCHEV
10-06-2006
289945
Les fonctions textes : CHERCHE
03-06-2006
210165
Les fonctions textes : NBCAR
29-05-2006
71083
Les fonctions statistiques : RANG
29-05-2006
96180
Les fonctions Recherche et Matrices : EQUIV
25-05-2006
116665
Les fonctions Recherche et Matrices : INDEX
25-05-2006
92240
Les fonctions statistiques : MAX
23-05-2006
25986
Les fonctions statistiques : MIN
23-05-2006
16798
Les fonctions textes : MINUSCULE
20-05-2006
24018
Les fonctions textes : MAJUSCULE
20-05-2006
25404
Les fonctions textes : NOMPROPRE
19-05-2006
30716
Les fonctions mathématiques : SOUS TOTAL
30-04-2006
124941
Les fonctions mathématiques : SOMME
26-04-2006
30809
Les fonctions statistiques : MOYENNE
26-04-2006
37932
Les fonctions statistiques : MOYENNE REDUITE
26-04-2006
50491
Les fonctions textes : CONCATENER
23-04-2006
147346
Les fonctions textes : DROITE
23-04-2006
50062
Les fonctions textes : STXT
23-04-2006
120612
Les fonctions textes : GAUCHE
23-04-2006
73336
Les fonctions logiques : OU
23-04-2006
257799
Les fonctions logiques : ET
23-04-2006
95655
Les fonctions logiques : SI
23-04-2006
111610
Les commentaires appartiennent à leurs auteurs. Nous ne sommes pas responsables de leur contenu.
Posté Commentaire en débat
Publicités